Thunderbird e-mail drag and drop

Forums / General Discussions / Thunderbird e-mail drag and drop

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #35189
    nxmac
    Participant

    I’m currently using the NoMachine player (7.6.2, “Show remote cursor pointer” & “Grab the keyboard input” selected) on a Windows (10, 2016 LTSB) PC to connect to an M1 Mac Mini (Big Sur, 11.5.2) with NoMachine server (7.6.2) that is running Thunderbird (78.14.0).  When trying to drag e-mails to different folders in Thunderbird, they often (almost consistently) fail to move.  Prior to my current scenario, I was connecting with [removed]’s viewer application (6.21.406 (r44671)) and not having this problem when connected to the same M1 Mac Mini (e-mails would seldom fail to move).  Prior to that, I was running Thunderbird on a Windows (7, Ultimate) PC and connecting from the same client using the MS Remote Desktop client and not having this problem (again, e-mails would seldom fail to move).  When e-mails failed to move on Windows or on the Mac Mini using VNC, it was clearly because the pointer was not touching the text of the folder, and you could tell because the text wouldn’t be highlighted (so it was arguably user error / poor Thunderbird UX).

    When e-mails fail to move on NoMachine, the text appears highlighted, but trying to make sure the pointer is on the text doesn’t seem to make a difference, either.  I also noticed a folder’s text continue to appear highlighted when I wasn’t pointing at it in one case, and I had to close and re-open in order to get that display artifact (presumably) to clear.  Does anyone else happen to use NoMachine and Thunderbird and have similar issues dragging e-mails from one folder to another?

    #35216
    Britgirl
    Keymaster

    We tested on the fly connecting from Windows to M1 Mac (Big Sur) with the latest Thunderbird program downloaded from the Thunderbird website. There are no issues with dragging emails from one folder to another within the email program during a NoMachine session. Is it possible for you to try with another email application? Is it possible for you to try with a more recent version of Thunderbird?

    #35218
    nxmac
    Participant

    Thanks for testing, I posted in general thinking I could get random input from some subset of users that do use Thunderbird (because I doubt this issue has to do with M1 Mac specifically).  AFAICT, the version of Thunderbird I mentioned is the latest (says it is up to date in the About screen after appearing to refresh). I tried enabling “Grab the mouse input” and that seemed to help a little bit (though I’m not sure why it would considering that I’m using full screen anyway), but the issue still seems more present than it was with VNC, RDP, or locally.  Specifically, I moved 8-10 e-mails, one at a time, to a few different folders, and about half of them moved on the first try where the other half moved on the second try.  Prior to changing that setting and starting this discussion, I was seeing enough 2nd and 3rd try failures that I was giving up and using the right-click menu to move the e-mails.  That’s a small test in a short period of time, so it’s possible that the better results were a fluke.  Unfortunately, the mouse input capture change makes the VNC to wake NoMachine to connect workaround a bit more difficult, so I’ve turned it back off regardless.

    I also tested with RealVNC’s viewer again after the test above, just to be sure, and I moved at least 20 e-mails, one at a time, with every e-mail moving on the first try. Regarding moves on the first try vs a subsequent try, anytime the e-mail doesn’t move when I try to move it, I see the animation of the e-mail going back to the list as if I tried to drop it between folders.  Oddly, I just noticed that I can move e-mails to a folder without touching the text, so long as the text is highlighted, so my earlier discussion about the pointer not touching the text may not be relevant on Mac (pretty sure the latest version of Thunderbird in July was still only highlighting text when pointing at the text, but not positive if that changed this recently or differs between Mac and Windows).

    To be clear, I’m not convinced it’s actually a problem with NoMachine regardless, but wanted to see others’ experiences.  Also, there are some unique variables in my situation that the software may or may not be able to help with:

    • My mouse is set to a pretty high speed, so the cursor bounces about when I type or even try to hold it still.  I thought this could explain the issue in and of itself until learning that apparently touching the letters of the text is no longer necessary.
    • My Internet uplink at home is slow and flaky (cable is exposed and ISP doesn’t seem to care).  I though this could be countering the previous point when using VNC where NoMachine is much more efficient, but again, that doesn’t seem as relevant now.
    • I have had behavioral issues that may imply the server isn’t seeing the same thing as the client (folder text being highlighted when I’m not pointing at it [may have mentioned this in OP], inability to move the mouse to the bottom of the screen until disconnecting and reconnecting [dragging mouse down while holding an e-mail would do nothing, left and right would go left an right, up would go up, but down would stop at the same point higher than the bottom of the screen], holding modifier keys, but mouse actions act as if I’m not [this applies in and outside of Thunderbird, say I’m holding the “Command” equivalent and click on a link in Safari, it should open in a new tab, but sometimes opens in the same tab instead as if I wasn’t holding the button]).  It may be that poor Internet uplink could explain all of these along with the OP topic.
    • I’m connecting to my router using OpenVPN because the built-in screen sharing isn’t encrypted.  I’m not sure if that could further negatively affect NoMachine communication, but assuming NoMachine uses SSL (I’m under the impression that it does), I could open 4000 on the router to my Mac if that would be better.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.