Trouble connecting to Linux Mint XFCE desktop

Forums / NoMachine for Linux / Trouble connecting to Linux Mint XFCE desktop

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #37098
    grundar
    Participant

    Hi,

    I want to connect to a remote computer running Linux Mint 20.3 with pre-installed xfce desktop.

    If I logged in with NoMachine using the physical display all is ok. See first image with the black linux mint screen.

    If I logged in using NoMachine virtual desktop I got an very old-styled desktop of xfce. See the second image with the blue xfce-screen.

    My /usr/NX/etc/node.cfg has the normal xfce start-command:

    DefaultDesktopCommand /usr/bin/startxfce4

    What can I do to get the modern Linux Mint xfce desktop in the virtual desktops?

    I installed NoMachine Workstation (Evaluation).

    Did you need some more infos?

    Thanks for your help

    Grundar

     

    #37150
    fisherman
    Moderator

    I did not check startup scripts for the Linux Mint that loads correct theme on physical desktop. NoMachine starts command you mentioned in your post. I can recommend workaround that possibly you can use.
    – Remove existing xfce settings for that user that has loaded standard xfce desktop.
    rm -rf ~/.config/xfce4 or rm -rf /home/user/.config.xfce4
    – log to the desktop with user physically or using NoMachine physical session
    – then logout
    – Create virtual desktop session

    #37153
    grundar
    Participant

    Thank you for your reply. I tested your workaround. But without any success. After the login via NoMachine the physical desktop is also “damaged”. Removing the xfce-config folder rebuild the desktop only in some parts. for example: the menu and the taskbar are in the old-style or corrupt.

    And the virtual desktops were not affected by this action.

    That way didnt work. 🙁

    Any suggestions?

    #37158
    Britgirl
    Keymaster

    There was a typo in the previous reply. Could you try with the following and tell me if that works:

    rm -rf /home/type_username_here/.config/xfce4

    then follow the steps as before (log in to desktop using NoMachine physical session, logout, create virtual desktop session)

    #37163
    grundar
    Participant

    Now I tried some steps around, but there was no success.

    I made a fresh install of NoMachine Workstation.

    I edit /usr/NX/etc/server.cfg and activated the physical desktop to all users with

    PhysicalDesktopSharing 1

    Add a new desktop user

    Reboot the machine

    Connect the desktop user via NoMachine

    Logged in the desktop-user with the physical desktop – and logged out

    Canceled the connection and reconnect with NoMachine.

    Create a new virtual desktop.

    Now I see the (wrong) blue xfce desktop.

    Then I logged out the virtual desktop and logged in with root and removed .config/xfce4 Folder from my desktop-user.

    Logged in the desktop-user with the physical desktop – and logged out

    Create with the desktop-user a new virtual desktop.

    Again I see the (wrong) blue xfce desktop.

    Than logged out and logged in the desktop-user with the physical desktop. Now I see the (good) black xfce- desktop with some little damages. Some icons in the taskbar are corrupt.

    Hmmm …? Very tricky. What can I do now?

    #37178
    Britgirl
    Keymaster

    We reproduced the same behaviour. But this seems to be more of a problem of Mint and not NoMachine. It can be fixed by setting the environment varible in node.cfg:

    DefaultDesktopCommand "env XDG_CONFIG_DIRS=/etc/xdg/xdg-xfce:/etc/xdg:/etc/xdg /usr/bin/startxfce4"

    This should be enough to get the correct desktop GUI. Since the desktop-user was already logged and probably you had “wrong” settings saved, you need to reset it with:

    rm -rf /home/desktop-user/.config/xfce4

    and then logging in to your NoMachine session should give you the desired DE.

    #37210
    grundar
    Participant

    Yeah! What a tricky option! But that rocks 🙂

    Thank you very much!!

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.