Trouble remotely accessing Linux from Windows

Forums / NoMachine for Linux / Trouble remotely accessing Linux from Windows

  • This topic has 7 replies, 3 voices, and was last updated 6 years ago by AvatarTor.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6982
    AvatarDavid4321
    Participant

    My desktop at home is Zorin 9 (Ubuntu variant, KDE desktop) and my travelling laptop is Windows 7. I want full remote desktop access to the Zorin system from the Windows laptop. NoMachine 4.5.0 for Linux, 4.4.6 for Windows.

    I’m completely new to trying this. I’m fairly advanced at Windows, and have been using Zorin daily for 6 months, it’s my first Linux system.

    After some searching I chose NoMachine as my client. I need quick real time responsiveness, directory access and file transfer, and I need to run applications on the Zorin from the Windows machine.

    I really need a step-by-step. Here are some questions:

    1) When I open NoMachine on Zorin, I see two ip addresses, one local and one remote. Both are nx://

    I created a connection using the local Zorin address (without the nx://) on Windows side, and this works perfectly with both systems on local LAN.

    Then I created another connection for remote access. When I take Windows off the WiFi (LAN) and put it on my phone hotspot to test remote connection, I get “Error is 11001: Host not found”

    I have tried editing remote connection to include the nx://, and to include and exclude the 5 digits after the colon in the remote ip, and same result.

    What have I got wrong, and how can I get remote connection?

    Thanks for any help!

    #6990
    AvatarBritgirl
    Keymaster

    Hi,

    that error can come up when there has been a misspelling in the IP address. For example, 10.0.0.1;111 instead of 10.0.0.1:111. Are you able to check in the client logs, so that we know for sure what IP you inserted?

    https://www.nomachine.com/DT04M00076#6

    #6992
    AvatarDavid4321
    Participant

    Here’s the log.

    #6991
    AvatarDavid4321
    Participant

    Not a chance, I copied directly from NoMachine display and messaged it to myself on the other system. I just tried it again both with and without the nx:// – same result both ways.

    Thanks for more help.

    #7002
    AvatarBritgirl
    Keymaster

    Can you send the logs to forum[at]nomachine[dot]com?

     

    #7022
    AvatarDavid4321
    Participant

    Did you ever get the logs? I sent them Thursday morning, and haven’t seen a reply here or via email. I really need a solution, or I’ll have to abandon NoMachine and go another route.

    Thanks!

    #7034
    AvatarBritgirl
    Keymaster

    Yes, we did get the logs and your issue will be looked at as soon as possible.

    #7042
    AvatarTor
    Contributor

    David, logs show that you’re using the quick connection address format (copied from the NoMachine Client GUI on the server) as hostname in the Connection Wizard (clicking ‘New’), so the client cannot connect to the host because it cannot detect the right address. As quick solution, paste that address in the search field you see in ‘Recent connections’ dialog and press Enter.

    Please read also this article, it explains how to configure a connection:

    https://www.nomachine.com/getting-started-with-nomachine#internet

    Look at Fig.11 and Fig.12 in particular.

    Let me know if it helps.

Viewing 8 posts - 1 through 8 (of 8 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.