Trouble setting up connection over internet, uPNP enabled

Forums / NoMachine for Windows / Trouble setting up connection over internet, uPNP enabled

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10878
    matt29649
    Participant

    I tried looking for the answer but everything I find tells me that I need to have uPNP enabled in order for the external ip to show up when opening NoMachine. I’ve checked and I had it enabled but still cannot connect. Local connections work fine but I’ve been trying for about 2 hours now to get a connection over the internet to work without any luck.

    Thanks for your help

    I’m using free version, both computers are windows 10.

    #10880
    kroy
    Contributor
    #10884
    matt29649
    Participant

    Any help would be greatly appreciated.

    #10893
    Britgirl
    Keymaster

    Take a look at the posts suggested by Kroy.

    #10902
    matt29649
    Participant

    Sorry, I guess that post was still under moderation when I posted.

    No, those topics are not related to my issue. Both of those people have issues trying to connect, but ARE getting the external IP to show up during the welcome screen. When I open NoMachine the only number that shows up in the welcome screen is the internal IP. I have also tried getting the external IP elsewhere and then setting it up manually but that doesn’t seem to work either.

    From my research the solution to the external IP not showing up has been “Make sure uPNP is enabled”. My problem is that it is enabled and that was the only suggestion I could find.

    Thank you.

    #10909
    kroy
    Contributor

    Please try port forwarding. Configure your router manually to pass traffic to port 4000 (NX protocol). There is an article with instructions on how to connect to NoMachine when the server is behind a NAT router or a firewall https://www.nomachine.com/AR11L00827. Read part “IMPORTANT”, there is instruction: “if the router doesn’t accept UPnP or NAT-PMP commands, it will be necessary to configure it manually through its administrative interface.”

    Can you also write here information about router? Name, version, firmware. There is native software or openwrt?

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.