Trouble staying connected on Windows 10 Home laptop

Forums / NoMachine for Windows / Trouble staying connected on Windows 10 Home laptop

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #16911
    astrojohn
    Participant

    Problem started recently, prior to current failure I had no issues.

    Here’s the scenario: client is running on Linux Mint 18.3 and I can connect to my Windows 10 Pro desktop with no problem (and vice versa).  My Windows 10 Home laptop is another story.  I can connect for a few seconds, the laptop wakes up (or may have already been awake), I get the message on the laptop screen that my client has connected, and then it disconnects leaving me with a white screen on the client.  Same thing happens if I connect from my Windows 10 Pro desktop or from an iPad.  Settings in the Windows machines are identical and I even tried uninstalling the latest server software and going back to an earlier version of NoMachine on the laptop.  Still doesn’t work. Also, all computers are on the same network, the Linux and Windows machines are hardwired.

    I can run Remmina on the Linux machine connecting to VNC on the laptop and it works. And Linux->Pro desktop works with NoMachine.

    Any ideas?

    NoMachine Version 6.0.66 (Windows 10 Home and Pro), free versions

    NoMachine 5.3.12-14 (Linux Mint 18.3 Cinnamon) from repository

     

    The message I get is:

    The connection with the server was lost.

    Error is 110: Connection timed out.

    John

    #16921
    kroy
    Contributor

    Hi.

    We coudn’t reproduce this problem. Can you enable debug, restart nxserver and send server logs from server side and please collect also player logs from client side (it’s ~/.nx folder on your Mint). You can send them to forum[at]nomachine[dot]com? Instructions about debug and collecting logs you can find there: https://www.nomachine.com/<wbr />DT07M00098.

    #16925
    astrojohn
    Participant

    Error logs attached (also sent them to forum@…etc per instructions).

    Attachments:
    #16935
    kroy
    Contributor

    Please try to disable acceleration for display processing in the server preferences GUI (https://www.nomachine.com/AR02L00782) and let us know if that helps.

    #16939
    astrojohn
    Participant

    No difference.  Connects, then immediately disconnects.

    #16958
    kroy
    Contributor

    Did you restart nxserver after changes? Please try also enable “Use a specific display encoding” and set it to VP8 before restart.

    #16975
    astrojohn
    Participant

    Yes, I restarted the server.  VP8 was the default but I set it anyway.

    Also tried completely uninstalling it, ran ccleaner and bleachbit to be sure I got everything, reinstalled the latest version.  Now neither server nor Windows client works. I can connect from the laptop TO my linux machine but now I get a frozen image of my linux desktop on the laptop.  But my other windows machines work fine between themselves and Linux.

    Something is amiss in the laptop but I think its time to give up – it’s my other machines where I really need the remote capabilities anyway.  Thanks for the help.

     

    John

    #17003
    Britgirl
    Keymaster

    NoMachine 5.3.12-14 (Linux Mint 18.3 Cinnamon) from repository

    In a previous post you wrote this. I’m not sure which repository you mean since our official packages are only available directly from our website. Can you confirm where you downloaded from?

     

Viewing 8 posts - 1 through 8 (of 8 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.