Trouble with copy and paste

Forums / NoMachine Terminal Server Products / Trouble with copy and paste

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4955
    etphipps
    Participant

    I am having trouble with copy and paste working reliably between the client machine I am connecting from and the virtual session I am connecting to.  Ever since I began using NoMachine 4 I have had trouble with the clipboard not always being updated between the client and the session.  Usually I can, e.g., copy some text in the virtual session and paste it into an app on the client or vice versa.  However this quits working intermittently and if I e.g., copy some text in the virtual session and try and paste it in an app on the client, the clipboard is not updated with whatever I just copied.  It will work fine for a while, quit working for a while, and then suddenly start working again (without even closing down the session).  So far I have not been able to determine what causes it to stop working, nor what gets it to start working again.  Currently I am running the 4.3.24 workstation server on a Centos 6.5 linux machine and connecting to a virtual session through the 4.3.24 enterprise client on OS X 10.9.5.  I would be happy to provide more diagnostic information if someone can tell me what to look for.

    #5236
    Britgirl
    Keymaster

    The next update will fix some copy and paste issues that we have reproduced in virtual desktop sessions. Thanks for taking the time to report.

    #5293
    wernermaes
    Participant

    Hello

    With “the next update” did you mean 4.3.30? Because I still experience copy/paste issues.

    In my case:

    I copy some text in my system, try to copy it to the NX session but what’s being copied is the buffer that was present in my NX session, not the text I selected in my system.

    It’s a virtual desktop session

    Kind regards

    Werner

    #5298
    graywolf
    Moderator

    Werner, have you upgraded both client and server? Fixes to copy and paste in 4.3.30 are client-side only.

    Could you provide more details about:

    • The operating systems of the client and server hosts
    • The desktop environments (Gnome, KDE, etc) in use and their versions
    • The applications from/to you tried to copy/paste unsuccessfully.

    Thank you.

    #5299
    wernermaes
    Participant

    NoMachine client 4.3.30

    NoMachine Small Business Server 4.3.30

    Server OS: Red Hat Enterprise Linux Server release 6.6 (Santiago), with KDE 4.3 or Gnome 2.28.2

    Client OS: Windows 7 Enterprise, Sp 1

    Copying from eg Internet Explorer address-bar into a shell running in KDE Konsole occasionally stops working.

    Copying from Notepad++ to Gedit on Gnome does not work (it prints the copy buffer from the NX session)

    #5322
    wernermaes
    Participant

    Hello

    Apparently my client version is still 4.3.24. I’ll upgrade it and I’ll keep you informed.

    #5353
    wernermaes
    Participant

    Hello

    It seems to work fine after updating my client to 4.3.30

    Thanks

    Werner

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.