Troubleshooting frequent reconnects

Forums / NoMachine for Windows / Troubleshooting frequent reconnects

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #3545
    samo_dadela
    Participant

    nx 4.2.22_1 windows client -> linux (fedora 20) server

    I noticed frequent reconnects from the windows client to linux server… to the point where nx becomes unusable. About 1 every 1-2 minutes, sometimes it works for 5 minutes – the reconnects takes from 5 to 20 seconds. The link is fiber optics 10/10 Mbps connected via VPN.

    To exclude network problems I also opened a VNC session from the same windows machine to the linux box. When NX does the reconnecting thing VNC is still responsive. VNC sometimes does hick-up but for 1-2 second max and very rarely.

    I tried to change the settings like quality, network adapitve updates with no improvement. Disabling UDP doesn’t help also.

    Is there a way to enable debugging on the client/server so that I can see what the problem is?

    #3592
    samo_dadela
    Participant

    Found the problem. It seems that my VPN client adapter MTU was too high. I lowered the MTU and now the reconnects are few and far apart. If reconnect happens it eventually connects (before it was hanging).

    Anyway… would be nice to know how to troubleshoot such problems? Can logging be enabled?

     

    #3630
    fra81
    Moderator

    Logging can be enabled for the server by enabling this key in the /usr/NX/etc/node.cfg and server.cfg files:

    SessionLogLevel 7

    However problems with network outage are more likely to be identified by looking in the .nx directories in the user’s home on client and server side (more info in https://www.nomachine.com/AR07K00677 on how retrieving logs). You may notice logs similar to “WARNING! No data received […] since […] ” or any other actual error. Log level cannot be changed there, but default should be enough.

    #3871
    samo_dadela
    Participant

    Installing the 4.2.23 Windows client solves the problem. Seems it was not the MTU after all.

     

     

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.