Trying to add SSH key, missing directory in home

Forums / NoMachine for Linux / Trying to add SSH key, missing directory in home

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #24613
    Avataralgaelagoon
    Participant

    I’m trying to add the SSH key to $HOME/.nx/config but these directories do not exist in my home directory after install NoMachine.

    I’m on a fresh install of Ubuntu 18.04.

    The permissions on my home directory are 755.

    I install NoMachine using the instructions found here:

    https://www.nomachine.com/DT02O00124#2.7

    Please advise.

    #24616
    Avataralgaelagoon
    Participant

    I solved this by creating the $HOME/.nx/config directories and then creating the authorized.crt file myself, adding the key in there after converting it to a plain openSSH key and setting the file permissions to 0600 on authorized.crt.

    #24648
    AvatarBritgirl
    Keymaster

    The correct article to look at is:

    How to set up key based authentication with NX protocol
    https://www.nomachine.com/AR02L00785

    #24674
    Avataralgaelagoon
    Participant

    Thanks for replying. Yeah, that’s the one I was looking at. I was expecting that the file might not be there since the instructions said that, but the directories were missing also, which is what got me confused. It could be helpful to update those instructions for people in the future.

    #24679
    AvatarBritgirl
    Keymaster

    Hi, it has been updated already, see point 1.

    “….Add the public SSH key on the server

    1. Navigate to the <user’s home>/.nx/config directory.
    Create this directory if it doesn’t exist.

    2. You should find there the authorized.crt file. Create this file if it doesn’t exist. On Linux/Mac, this file needs to have permissions set to 0600…..”

    #24682
    Avataralgaelagoon
    Participant

    Great, thank you.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.