Ubuntu 17.10 doesn’t show my physical display in the list

Forums / NoMachine for Linux / Ubuntu 17.10 doesn’t show my physical display in the list

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #17179
    bwyazel
    Participant

    I have installed NoMachine Enterprise Workstation on my computer running Ubuntu 17.10 with the Gnome desktop and GDM, and even though I have a physical monitor connected to my computer any NoMachine client that connects doesn’t show the current X server, it only shows the option to create a new virtual server

    Secondly, I have disabled GDM wayland in /etc/gdm3/custom.conf by uncommenting the line WaylandEnable=false, and I can confirm that the X server is running as I can connect into it though x11vnc.

    Basically, I don’t want to use x11vnc, and would rather use NoMachine, but NoMachine won’t show the physical display

    #17194
    og00r
    Contributor

    Just to be sure, what version of NoMachine do you have? I don’t recognize NoMachine Enterprise Workstation.

    After disabling wayland did you reboot machine?
    Is it on login window or some user is currently logged?

    To be sure can you paste output of command “ps -ef | grep X”?

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as closed, you can't post.