Ubuntu 20.04 black screen with physical display

Forums / NoMachine for Linux / Ubuntu 20.04 black screen with physical display

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #38152
    Topnotchprincess
    Participant

    Hello,

    I have NoMachine 7.9.2 (Free) installed on both client and server side. Basic info:

    Server – Ubuntu 20.04, Awesome WM, NVIDIA RTX 1080 Ti w Driver 460.91.03, Desktop w 2 physical monitors

    Client – Ubuntu 20.04, Awesome WM, Laptop

    Connecting using the NX protocol gets me a black screen. Server & client side logs attached.

    #38268
    fra81
    Moderator

    Hi,

    are the 2 physical monitors turned on? How are they connected to the server (HDMI, Displayport…)?

    From the logs it seems you are connecting to the server’s login screen. Do you still get a black screen if the server is logged on to the user’s desktop?

    Can you try to disable hardware encoding as shown in https://knowledgebase.nomachine.com/DT11R00180#2.5?

    #38288
    Topnotchprincess
    Participant

    The monitors are connected via HDMI to one of the GPUs and are turned on. I am logged in to the same user account on the desktop.

    I restarted the server after disabling hardware encoding, still get the black screen 🙁

    #38407
    bucu
    Contributor

    @Topnotchprincess

    Hi,

    can you provide us the output of the “xrandr -q” command on server side? Have you tried lowering the screen resolution before connecting with NoMachine? Lastly – does Awesome WM supports scaling like @chiao has described?

    #38411
    Topnotchprincess
    Participant

    Thank you for your reply.

    I have attached the xrandr output as well as my startup script that sets up the dual display. Lowering the resolution has no effect; I don’t think any decimal scaling is applied.

    Interestingly, I was able to connect to my my laptop (Ubuntu 18.04 + Awesome WM) from my desktop. So the problem is either with

    1. dual monitors

    2. interaction between Ubuntu 20 / Awesome / NoMachine

    I tested #1 by disconnecting one of the monitors but still got a black screen. Any suggestions?

    #38429
    Britgirl
    Keymaster

    To Topnotchprincess, submit those attachments from your earlier reply to forum[at]nomachine[dot]com. Thanks

    #38430
    Topnotchprincess
    Participant

    Sent.

    #38466
    bucu
    Contributor

    Topnotchprincess

    is the black screen present also with different WM?

    For further investigation we would need a new set of logs from server side. Please make sure that you are connecting to the user’s session (not the login window one). You can follow this link to be sure you get all the logs.

    #38567
    Topnotchprincess
    Participant

    No black screen when connecting to Ubuntu/Unity desktop environments. Server side logs for a failed connection to Awesome WM are attached.

    Please note that I used the same set of credentials to connect to both sessions (Unity & Awesome) – this is the same set I use to login to my desktop session.

    #38611
    bucu
    Contributor

    Unfortunately logs you have sent are from login window not from a session using Awesome WM.
    To get proper logs:
    1. before connecting with NoMachine make sure that the user is logged in and Awesome WM is running
    2. on server side execute: sudo /etc/NX/nxserver --debug --enable all
    3. connect with NoMachine to server machine and make sure that the problem is reproduced.
    4. on server machine execute: sudo /etc/NX/nxserver --debug --collect

    You mentioned you have nvidia GPU. Is the problem present when using nouveau drivers? One more thing we noticed is that the “primary” output is disabled. Can you please remove your randr script and see if with default configuration you still get black screen?

    #38614
    Topnotchprincess
    Participant

    That is exactly what I did – I’ve been logged in throughout all of the above responses/attempts in this thread. The login screen issue might be pointing towards the problem – maybe something to do with the login manager and awesome?

    I haven’t tried using nouveau – it’s likely not the cause since I can connect when logged into Gnome on the server. The issue sticks without the xrandr config script; even when I set one of the monitors as primary or use an alternate monitor config (eg mirror), the black screen persists.

    What is the root cause of black screen – NoMachine not being able to detect a running graphical environment? How does NoMachine check that one is running?

    #38618
    Topnotchprincess
    Participant

    I’ve noticed that on my laptop where the server works well, it says ‘Desktop shared’ in the server status, however, on my desktop where it doesn’t work it says ‘Desktop not shared’. Therefore, there has to be something that’s preventing NoMachine from recognizing a running GUI.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.