Unable to configure router

Forums / NoMachine for Linux / Unable to configure router

Tagged: , , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10801
    Avatarcanufrank
    Participant

    I don’t use UPnP. I don’t plan to- it is inherently insecure.

    This article https://www.nomachine.com/AR11L00827 contains some nonsensical instructions on opening ports, but I have more than a little experience doing this for other services.

    I use a static IP for my Ubuntu server. I opened port 4000 on the router (both UDP & TCP) and pointed it to my server’s local IP. I then restarted the NX service, but at no point did the list of IP addresses update with my public IP.

    Also changed to a custom service port (also forwarded on router) and restarted- still no IP listed except the LAN local.

    Also forwarded the pre-filled GW port (spoofing UPnP) and tried to enable ‘Gateway port’ checkbox. The GUI returns ‘Failed to map the port on the gateway’ and unchecks the option. (I tried this with a custom Service port too- no difference.)

    I can only connect to this server from another LAN client. What is required to allow WAN connectivity?

    #10812
    Avatarkroy
    Contributor

    Hi.

    Also changed to a custom service port (also forwarded on router) and restarted- still no IP listed except the LAN local.

    NoMachine would list your public IP if you had enabled UPnP.

    What is required to allow WAN connectivity?

    Are you sure you are connecting to correct IP? On NoMachine you have only local IP since you’ve disabled UPnP. You can find your public IP by using whatismyip[dot]com, for example. That is what you should use to connect to your machine over WAN.

    #10817
    Avatarcanufrank
    Participant

    “NoMachine would list your public IP if you had enabled UPnP”

    What I was expecting was that NoMachine would test if it could communicate on that port, and if it could, would display the IP:port combination.

    So, because, NoMachine was only displaying the local port, I assumed that it wasn’t getting communications. I never actually tested connectivity. Once I did, I could connect from the WAN with no issue. So, I’m happy about that 🙂

     

    I would suggest that if port 4000 or whatever the user has set it to are already open, the Connection Status window should reflect that- it hardly matters whether or not UPnP is enabled.

    Similarly, if the user clicks GW and the (uneditable prefilled) port is found to be already open, there should never be an error message, as it doesn’t matter that the application cannot map the port.

    Finally, the GW port should be made editable if UPnP is not being employed (an additional check box too).

    #10826
    AvatarBritgirl
    Keymaster

    We don’t have any plans to make changes to how UPnP in the near future is handled, but your suggestions are very much appreciated and we’ll certainly take them into consideration for our roadmap 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.