Unable to connect

Forums / NoMachine for Linux / Unable to connect

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #219
    Avatartuuk
    Participant

    Hi,

    I have installed No Machine on two Ubuntu 13.04 machines. However, I am having difficulty connecting from one to the other. As the server (i.e., the machine I would like to connect to) is behind a firewall, I use VPN.

    I choose “SSH” for connection type as “NX” cannot connect at all (could be a port issue with my router, that is, with incoming traffic on port 4000).

    Even though I can ssh to my server on the command line, no machine connection (via ssh) is lost soon after I enter my password on the server. The log file “connection” contains

    =====
    Warning: No xauth data; using fake authentication data for X11 forwarding.
    Welcome to Ubuntu 13.04 (GNU/Linux 3.8.0-32-generic x86_64)

    * Documentation: https://help.ubuntu.com/

    New release ‘13.10’ available.
    Run ‘do-release-upgrade’ to upgrade to it.

    Linux
    NX> 900 SSH connections are not supported on this server.
    =====

    At the moment, I am away from my computer and has no access to the “session” log, but I can include that later.

    Does the above give any clue as to why this problem might be occuring?
    What is this “Warning: No xauth data; using fake authentication data for X11 forwarding” message?

    Thanks,
    Tugkan

    #228
    Avatartitan
    Participant

    Please check my post:

    http://www.nomachine.com/forums/forums/topic/after-upgrading-freenx-from-3-5-to-4-i-have-connection-problems/#post-223

    I understand it’s not as easy as before, but why don’t you just tunnel the NX connection?

    ssh -L 4555:localhost:4000 youruser@yourhost

    Now connect to nx://localhost:4555

    Remember to disable UDP in the connection settings or you will have to wait for the UDP negotiation timeout.

    #250
    Avatartuuk
    Participant

    Thanks Titan. That solved my problem. Greatly appreciated.

    I have a slight nuisance due to multiple monitors on the server, but I should probably start a new thread for that.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.