Unable to get audio working 10.14

Forums / NoMachine for Mac / Unable to get audio working 10.14

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #34481
    Matt Behar
    Participant

    After installing the NoMachine client on my Mac, I’m not seeing any audio devices listed under the sound output preference pane.

    I’m unable to select any NoMachine audio device. I’ve tried to uninstall/reinstall and even tried the latest build available but the same results.

    #34502
    Carin
    Participant

    Hi Matt,

    Did you approve kernel extensions as explained in this article? https://knowledgebase.nomachine.com/AR01P00962
    If not, please do it and let me know the outcome. Thanks!

    #34557
    Matt Behar
    Participant

    I’ve tried to reinstall the application, but I’m not getting the prompt to approve the kernel extensions.

     

    Is there a way to force that to happen again?

    #34566
    Britgirl
    Keymaster

    Try going to Microphone permissions (both client and server sides), uncheck and check NoMachine but on both hosts
    – restart player on client side
    – restart NoMachine server on server side

    Does this help?

    #34569
    Matt Behar
    Participant

    I reset the permissions on both sides, but the server still does not list NoMachine as an available hardware device.

    #34576
    tsotne
    Participant

    Hi Matt,
    1. let’s load nxaudio kext manually:
    sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext/

    2. if you did not approve it, do::
    Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button

    3. if it finished without any error, check if it’s loaded properly:
    kextstat | grep nxau

    you should get similar output:
    180 0 0xffffff7f83d9c000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <93 6 5 3 1>

    4. restart NoMachine server:
    sudo /etc/NX/nxserver --restart

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

    #34582
    Matt Behar
    Participant

    After loading the nxaudio kext, it never prompts to allow permission in security.

     

    marketingmac08:~ root# kextstat |grep nxau
    168    0 0xffffff7f84c9c000 0x5000     0x5000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <97 6 5 3 1>
    marketingmac08:~ root# /etc/NX/nxserver –restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.
    marketingmac08:~ root# kextutil -vvv /System/Library/Extensions/nxaudio.kext/
    Defaulting to kernel file ‘/System/Library/Kernels/kernel’
    /System/Library/Extensions/nxaudio.kext appears to be loadable (not including linkage for on-disk libraries).
    Loading /System/Library/Extensions/nxaudio.kext.
    /System/Library/Extensions/nxaudio.kext successfully loaded (or already loaded).

    #34591
    tsotne
    Participant

    Hi again,
    kextstat output shows that it is loaded also, kextutil output would be different if you didn’t approve it, so you have done it already.

    You should have 2 NoMachine audio device.
    Can you attach audio MIDI setup’s screens (during the session, while you are connected to your mac)?

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.