Unable to get external IP to work

Forums / NoMachine for Windows / Unable to get external IP to work

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #39751
    EternalKing
    Participant

    Hey, would appreciate some help. I have the router from AT&T model: BGW320-500. I am unable to see the external IP on it. I enabled UPNP NX on the server.cfg as mentioned in other forum posts. I went ahead and did Port Forwarding to port 4000 and external port 24224 as shown in the server.cfg file I have to keep it the same, but when doing the enable default gateway it errors out and tells me I’m unable to “Failed to map the port on gateway”

    Just to clear it out, I enabled the port 4000 on my AT&T router and this is the info I get from the command prompt

     

    C:\Program Files (x86)\NoMachine\bin>nxserver –upnpmap

    Local IP                   192.168.1.65

    Gateway IP                 192.168.1.xxx

    External IP                64.17x.x.x

     

    C:\Program Files (x86)\NoMachine\bin>NXSERVER –upnpstatus

    Local IP                   192.168.1.65

    Gateway IP                 192.168.1.xxx

    External IP                64.17x.x.x

    Any help would be appreciated.

     

    #39779
    Britgirl
    Keymaster

    Hi, when you searched the forums, did you also find the article about how to connect over the Internet? And did you follow the tips there?

    How to connect over the internet to NoMachine behind a NAT router
    https://kb.nomachine.com/AR10R01099

    “Failed to map the port on gateway” suggests that the port you used in the port-forwarding rule on your router could already already be in use. Go back to your router and change the external port number to, for example, 24222, the restart the nxserver (NoMachine settings -> Server -> Status -> Restart) or you can do it from the commandline. For safe measure also restart UPnP.

    Open CMD as administrator and execute:

    c:\ProgramData\NoMachine\nxserver\nxserver.exe --restart
    c:\ProgramData\NoMachine\nxserver\nxserver.exe --upnpmap

    Is it possible there is a double NAT in place? If so, you will need to map the ports on both routers. So Router A must map to Router B and Router B to the computer you want to access.

    #39792
    EternalKing
    Participant

    I’ve gone through everything you mention and although I can see the external IP the port is not “binding” to it so I’m unable to use it, in the section where it states failed to map the port on gateway it’s greyed out and I can’t change it either. unsure if there’s something I can do there. I only have the 1 router so it’s not double NAT. Unless there’s something I’m missing there.

    #39811
    Britgirl
    Keymaster

    Can you check your External IP and compare with what’s showing, for example, on whatismyip.com? If IP addresses are different, then that would indicate indeed a double NAT.

    If it’s the same, I advice you to start again (remove old changes, basically to what you had before changing anything) and set Port Forwarding with for example 24222 (or other – but not 24224 which is used for UPnP which is what I’ve understood you’ve done).

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.