Unable to login as non root user

Forums / NoMachine for Linux / Unable to login as non root user

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #17872
    pitajnx
    Participant

    Hello everybody,

    I am using NoMachine for Everybody, version 6.0.78 on Oracle Enterprise Linux 7 virtual machine. I have installed NoMachine on Linux and after that I was able to login as user oracle without a problem. After a few days I have tried again but when I connect I have get blue screen with date and time but am not able to access login screen. I have tried to press various keys and mouse clicks but with no luck. After that I have configured root connection to the same Linux machine and it works without problem. In NX logs I could not find any errors. I am using gnome desktop on Linux.

    Thank you for your help

    Attachments:
    #17913
    mlyn
    Contributor

    Hello pitajnx,

    the described behaviour looks as if PhysicalDesktopMode 0/1 or VirtualDesktopMode 0/1
    are set in the server configuration file. This enables view only mode.

    You can verify by executing in cmdline:
    grep DesktopMode /usr/NX/etc/server.cfg

    By default it is set to 2 which is interactive. Try setting it back to 2 rather than 0 or 1.

    The key PhysicalDesktopMode setting  is used when we find an x server running.
    The key VirtualDesktopMode is used when we start nxframe buffer when we don’t find an x server running.

    If the output shows 2, please enable debug and share logs as described  here: https://www.nomachine.com/AR07K00677

    The logs can be attached here or sent directly to forum[at]nomachine[dot]com.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.