Unable to redirect printers

Forums / NoMachine for Linux / Unable to redirect printers

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7305
    Avatarmand1nga
    Participant

    Hello,

    I seem unable to redirect printers using the free client 4.5.0 on Linux/Mac platform against the free server 4.5.0 running on a Linux CentOS 6.6. I can connect to the server without problems but when I try to map a local printer using the client, none of my printers are shown in the local printers listing. Again, this situation happens from both the Linux and Mac clients, which makes me thinkg this might be a issue on the server.

    When I installed the NX server CUPS wasn’t installed, I’ve installed it afterwards and ran /usr/NX/scripts/setup/nxnode –printingsetup

    On the server I’m also running vnc and xrdp services, I’m using NX to connect to the virtual displays created by the vnc service.

    Thanks in advance,

    Saulo

    #7311
    Avatarmand1nga
    Participant

    I confirm the issue is still present after upgrading the player to 4.6.3 (server still 4.5.0). I’m attaching an image displaying the issue.

     

    #7323
    Avatarfrog
    Participant

    Hello,

    We are unable to reproduce this issue in our labs and in the same environment.

    We would like to suggest to uninstall the current server, clean-up the installation

    and reinstall the server from scratch:

    – Uninstall NoMachine from your server host using this command:

    sudo rpm -e $(rpm -qa ‘*nomachine*’) && sudo rm -rf /usr/NX/ && sudo rm -rf /etc/NX/

    – After uninstalling process completed, ensure that CUPS is properly installed

    – Install NoMachine server again (we have just released version 4.6.3 if you might

    want to upgrade). Then verify if the problem still exists.

    If the problem still exists, please let us know and we will send further instructions to resolve this issue.

    • This reply was modified 6 years ago by Avatarfrog.
    #7422
    Avatarmand1nga
    Participant

    The issue was gone after updating NoMachine, thanks a lot!

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.