Unable to start nxserver on RHEL 7

Forums / NoMachine for Linux / Unable to start nxserver on RHEL 7

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #13625
    ewinter
    Participant

    Hi all,

    I’ve scoured the forum and come up dry on this particular problem. We have installed the free version of NoMachine using the RPM: yum install nomachine_5.1.62_1_x86_64.rpm .

    The installation instructions provide no further direction than doing this. We have disabled our iptables-based firewall, but when we run the startup command, I see the following results (the “162” lines appear after a minute or so). Am I missing a step somewhere?
    [root@clsockeyev1 bin]# ./nxserver –startup
    NX> 161 Enabled service: nxserver.
    NX> 162 Disabled service: nxnode.

    NX> 162 Disabled service: nxd

    #13631
    Britgirl
    Keymaster

    Did you install NoMachine earlier and then uninstall before trying to reinstall again? Perhaps with a different NoMachine product? This could have caused problems with the license file for example. The best thing to do is uninstall again, remove the directory /usr/NX completely.

    sudo rpm -e nomachine && sudo rm -rf /usr/NX /etc/NX

    Then reinstall.

     

    #13639
    ewinter
    Participant

    Hmm. It was a fresh install. But we can try again and see if this helps.

     

    Eric

     

    #13646
    Britgirl
    Keymaster

    If the problem still appears please enable debug, restart nxserver (/usr/NX/bin/nxserver --restart) and send logs from server side to forum[at]nomachine[dot]com.

    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT07M00098.

    #13950
    ewinter
    Participant

    Hi, thanks for that information. I’m sorry I did not respond sooner – I did not see your response until I checked this morning. I think I was expecting an email (my bad, not yours).

    I did what you suggested, and attached are the logs. This was done after a fresh installation from the RPM. Attached is a tarball containing the /usr/NX/var/log contents: nxd.log (empty), nxerror.log (empty), nxinstall.log, and nxserver.log. I scanned through the contents of the non-empty files, and I can’t detect an obvious reason for the failure – but I’m no expert. FYI, this was run on a recently-upgraded RHEL 7 system (see below). Is there any other information that might help with debugging the problem?

    Thanks

    Eric Winter

    Space Telescope Science Institute

    [root@clsockeyev1 ~]# uname -a

    Linux clsockeyev1.stsci.edu 3.10.0-327.4.5.el7.x86_64 #1 SMP Thu Jan 21 04:10:29 EST 2016 x86_64 x86_64 x86_64 GNU/Linux

    [root@clsockeyev1 ~]# cat /etc/system-release-cpe

    cpe:/o:redhat:enterprise_linux:7.3:ga:server

    #13978
    Bilbotine
    Keymaster

    Hi ewinter,

    Are you using Active Directory, LDAP or similar environment?

    NoMachine installation allows to have nx as network user but it requires to create home directory on locally on the system. We can see from your logs that nx is already exist as network user. It could shares home directory over network and prevents to create home locally.

    #14063
    ewinter
    Participant

    Huh, did not know that. We are using Active Directory. I’ll try to manually create the home directory and see if that fixes the problem.

    Eric

     

    #14090
    ewinter
    Participant

    FWIW, the problem was related to what you indicated. We had to create local accounts and groups for nx, since the Active Directory account for that name was not working. Is this requirement discussed in the documentation somewhere? We will be putting NoMachine on a lot of systems here, and we’d like to know if changes to our environment will be needed.

     

    Thanks

    Eric Winter

    #14375
    Britgirl
    Keymaster

    Just to let you know that we’re investigating this further and will publish some information soon.

    #14412
    brotech
    Participant

    Hello,
    we added an article strictly related to your issue:

    Troubleshooting NoMachine in a Active Directory Domain
    https://www.nomachine.com/AR04O00925

    If you have any problems, let us know.
    Regards

Viewing 10 posts - 1 through 10 (of 10 total)

This topic was marked as solved, you can't post.