Upgrade failure 5.0.43 to .47, Linux Workstation license

Forums / NoMachine for Linux / Upgrade failure 5.0.43 to .47, Linux Workstation license

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8845
    bernd
    Participant

    Upgrading my licensed Linux Workstation NoMachine 5.0.43 to 5.0.47 fails for no apparent reason. OpenSuse 13.2, 64-bit, KDE.

    Accessing NoMachine Service locally to the Linux Workstation via physical display:

    The server status GUI informs me that an update is already in progress, even before I authorised such upgrade. Maybe something lingers on from the previous upgrade (to 5.0.43), but I am guessing here. NoMachine tells me that the server isn’t running, and it fails to start for reasons unknown to me. Clients fail to connect (no surprise since the server isn’t running).

    I tried ‘rpm’ on the console. Attempts to uninstall inform me that NoMachine isn’t installed. Attempts to upgrade tell me that the installation failed without further details.

    Suggestions how to either apply the upgrade or uninstall/reinstall will be most gratefully received.

    #8855
    hawk
    Contributor

    Hello,

    We aren’t able to reproduce your problem in our lab. We need more details. Could you run below commands, collect some logs and send output to forum[at]nomachine[dot]com, please?

    1) /usr/NX/bin/nxserver --version
    2) ps aux | grep nx

    And we need whole /home/<your_user>/.nx directory. The proper way how to do this is explained inside this link https://www.nomachine.com/DT04M00076#5

    • This reply was modified 6 years, 1 month ago by hawk.
    • This reply was modified 6 years, 1 month ago by hawk.
    #8859
    bernd
    Participant

    sent as requested.

    #8872
    hawk
    Contributor

    Unfortunately we will need some additional information. Those should tell us where the real problem is. Please run:

    1) md5sum nomachine-workstation-update_5.0.47_3_x86_64.rpm
    (run this command in the same place you was running command “rpm -Uv nomachine-workstation-update_5.0.47_3_x86_64.rpm” please)

    2)ls -ltr /etc/NX/ /etc/NX/server/localhost/

    and collect /usr/NX/var/log/nxinstall.log and /usr/NX/var/log/nxupdate.log (if it exist) files, send those information to forum[at]nomachine[dot]com, please.

    • This reply was modified 6 years, 1 month ago by hawk.
    #8876
    bernd
    Participant

    additional data sent as requested.

    #8892
    bernd
    Participant

    Looks like I solved the problem. FYI & for the benefit of other users, check out this thread here: https://forums.opensuse.org/showthread.php/510023-About-quot-Read-only-file-system-quot-error

    The crucial hint is this: “One of the changes of the latest systemd update is that it respects the “ro” boot option now and does indeed mount the root partition read-only if that option is present. Before it was just ignored.

    dmesg did indeed show that the system boots with ‘ro’.

    To fix this, I edited the boot loader command script (hit ‘e’ while the Grub boot menu shows, remove the ‘ro’ then reboot with F10). Have yet to figure out how to solve this permanently, but I could subsequently install the latest kernel update and apply the NoMachine 5.00.47 update.

    NoMachine folks, consider this case solved.

    #9215
    Britgirl
    Keymaster

    Thanks for letting us know.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.