USB devices cannot connect on Linux client Windows server

Forums / NoMachine for Linux / USB devices cannot connect on Linux client Windows server

  • This topic has 2 replies, 2 voices, and was last updated 6 months ago by hzw.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #37324
    hzw
    Participant

    Hi everyone,

    I’ve just set up NoMachine to connect my Linux notebook (Ubuntu 20.04) as client to a remote Windows system as server (Windows 11) (all physical displays).

    The only thing I cannot make work is connecting my USB devices. They are recognized under Linux and I can also select them under “Menu -> Devices -> Connect a USB Device”, however after selecting them and pressing “Connect” they start being loaded but the spinning wheel never disappears (see screenshot). This is the case for all devices I have tried, i.e. the SpaceMouse, a normal USB mouse and a webcam. I should add that I can use the mouse on the server anyway. My final objective is to use the SpaceMouse for controlling a software on the server.

    Do you have any ideas what else I should try or change in my configuration?

    Output of ls -l /usr/NX/bin/drivers/:
    `total 48
    -rw-r–r– 1 root root 48368 Feb  2 08:35 nxusb.ko`
    Output of lsmod | grep nxusb:
    nxusb                  32768  5

    I’m using the free versions of NoMachine Enterprise client 7.8.2.1 on Linux and NoMachine 7.7.4.1 on Windows.

    Let me know if I should append any other client or server logs.

    Thank you for all your help already in advance.

    Best wishes
    Henning

    #37330
    Giorgi-G.
    Contributor

    Hi,

    Can you please try to restart both machines, and after try to forward regular mouse first?

    In addition, questions that might help figure out what’s going on:

    – Do you see both local and remote devices under the “Menu -> Devices -> Connect a USB Device” tab?

    – Do you have a stable internet connection to the server machine with less than 30ms ping time?

    – Could you please send logs from both (client and server) sides? You can send them directly to forum[at]nomachine[dot]com.

    #37358
    hzw
    Participant

    Hi Giorgi,

    Thanks for your reply and suggestions.

    It’s a bit embarrassing, but that already did the trick. I could indeed not see any USB devices on the remote system (=server). After waking up from suspend mode everything worked now, i.e. I could see the devices as well as connect the SpaceMouse.
    Just for reference purposes: For some reason I needed to install the official 3Dconnexion drivers from their webpage to make it work via NoMachine even though it had worked without it when I connected the mouse directly to the server PC before.

    Best wishes
    Henning

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.