USB extension popup not showing with macos 11.5

Forums / NoMachine for Mac / USB extension popup not showing with macos 11.5

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34592
    raresthornet
    Participant

    Hi guys,

    Hope everyone is well. I tried to search if there’s an issue open with this topic but I can only find an old one with NoMachine v6 so I guess here we go again.

    I’m trying to forward my usb mouse to my remote Windows host from my Macbook (x86) running Big Sur 11.5 but there’s no usb devices listed and neither a popup to allow the NoMachine usb extension to load.

    I tried to manually load the kext but no game :/ I also tried to disable system integrity protection in recovery mode before running it.

    kextload /Applications/NoMachine.app/Contents/Frameworks/bin/drivers/nxusbvhci_11.0.kext/Contents/MacOS/nxusbvhci_11.0

    Executing: /usr/bin/kmutil load -p /Applications/NoMachine.app/Contents/Frameworks/bin/drivers/nxusbvhci_11.0.kext/Contents/MacOS/nxusbvhci_11.0

    Error Domain=KMErrorDomain Code=71 “Loading extension failed: Unable to create bundle from path: /Applications/NoMachine.app/Contents/Frameworks/bin/drivers/nxusbvhci_11.0.kext/Contents/MacOS/nxusbvhci_11.0” UserInfo={NSLocalizedDescription=Loading extension failed: Unable to create bundle from path: /Applications/NoMachine.app/Contents/Frameworks/bin/drivers/nxusbvhci_11.0.kext/Contents/MacOS/nxusbvhci_11.0}

    Anyone knows why is this happening almost every macOS upgrade? NoMachine is not the only program that I have problems loading kext modules and its becoming really annoying.

    Thanks!

    #34728
    Giorgi-G.
    Contributor

    Hi,

    Can you please run this command to load the driver?

    sudo kextload /Library/Application\ Support/NoMachine/Extensions/nxusbvhci_11.0.kext/

    If there are no errors after launching the command, please run this one and check if the driver is loaded

    sudo kextstat | grep nx 

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.