USB forwarding from Windows to Mac fails

Forums / NoMachine for Mac / USB forwarding from Windows to Mac fails

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #32431
    Avatarkayvman1
    Participant

    Hello,

    I have been having problems attempting to forward usb devices from my windows client to mac host. I assume it is an issue with the server but I may be wrong. My server is a mac mini running Big Sur. I have attached the logs from my mac created after attempting to connect my iPhone to the remote pc. On the client I see a read ! next to any device I attempt to forward.

    Please let me know if you have any clue as to what is going on.

    Thank you for your time,

    kayvman1

    #32484
    AvatarGiorgi-G.
    Contributor

    Hi,

    I clearly see that there is some issue with loaning nxusb kexts on your macOS machine.

    Can you please share what macOS version you use?

    As well, you can try to update macOS and re-install NoMachine on it.

    To check the loading of drivers on the macOS machine run these commands.

    1. Close the NoMachine.

    2. Unload all drivers
    sudo kextunload /Library/Application\ Support/NoMachine/Extensions/nxusbvhci.kext/
    sudo kextunload /Library/Application\ Support/NoMachine/Extensions/nxusbvic.kext/
    sudo kextunload /Library/Application\ Support/NoMachine/Extensions/nxusblog.kext/ 

    All of these commands should fail with the reason: “(libkern/kext) not found”

    Sample:
    (kernel) Kext com.nomachine.kext.nxusblog not found for unload request.
    Failed to unload com.nomachine.kext.nxusblog – (libkern/kext) not found.

    If you have any other output, please restart your machine and try again.

    3. Load drivers to check that they are allowed in security preferences to be loaded.
    sudo kextload /Library/Application\ Support/NoMachine/Extensions/nxusbvhci.kext/
    sudo kextload /Library/Application\ Support/NoMachine/Extensions/nxusbvic.kext/
    sudo kextload /Library/Application\ Support/NoMachine/Extensions/nxusblog.kext/ 

    4. If you see such an error:

    /Library/Application Support/NoMachine/Extensions/nxusbvhci.kext failed to load – (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

    That means that the user has to approve kext loading in the Security Settings, as described here: https://www.nomachine.com/AR01P00962

    Such output also should be followed by a system pop-up, with the button: Open security Preferences.

    Once this is done for one kext, do that for the rest two ones, by launching the appropriate kextload command as described above.

    After this is done for all three drivers, restart your system and check USB functionality.

    5. If after launching the commands from step 2 you don’t see any output, that means that drivers are well loaded. Please run all three commands and after that run this command, to check that they are loaded:

    sudo kextstat | grep nxusb 

    The output should contain three lines with this kext ID’s:
    com.nomachine.driver.nxusblog
    com.nomachine.driver.nxusbvic
    com.nomachine.driver.nxusbvhci

    If you see such output, restart the machine and check the USB functionality.

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.