Use NoMachine together with ngrok for accessing remote access on Jetson

Forums / NoMachine for Linux / Use NoMachine together with ngrok for accessing remote access on Jetson

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #32817
    Avataracro
    Participant

    I have a client where I need to do some updates and support on a system running Ubuntu on Jetson Xavier NX. First I was thinking of using [removed] but it is not supporting arm64. The same scenario with [removed] and others …

    I tried to use NoMachine which works fine when running on the same network. I tried to make it work from outside (from the internet) by running it together with services like [ngrok] or [localtunnel] but it can’t get it to work and I might misunderstand some of the concept. This is what I have done:

    1. installed NoMachine and ngrok on Jetson
    2. run NoMachine-service and start the server
    3. the server says nx://172.20.10.12 and ssh://172.20.10.12. It runs on port 4000

    Here comes what I might misunderstand. My idea is to use ngrok to fetch the NoMachine so I can access it from a webpage from anywhere instead of running it from my another computer on the same network.

    After I saved my accesstoken for ngrok I tried by typing:

    ./ngrok tcp 172.20.10.12:4000

    But it didn’t work.

    Any idea how I can get this to work, basically to access my jetson from remote.

    #32842
    AvatarCarin
    Participant

    Hi acro,

    You may check this article:AR11L00827 – How to connect to NoMachine when the server is behind a NAT router or a firewall. If your router supports UPnP you can use this option to connect over the internet. In the article, you can find instructions on how to enable UPnP in the NoMachine server.

    Please take also a look at How to get started with NoMachine – section: Using NoMachine for remote access to a computer over the internet.

    If you want to forward port manually you should pass traffic to port 4000 (NX protocol), 22 (SSH protocol on Linux/MacOSX) or (4022) (SSH protocol on Windows). Follow your router instructions to know how to do that (guides you can also find on the internet, for example from here: https://portforward.com/router.htm).

    #32847
    AvatarCarin
    Participant

    Hi acro,

    We have tested ngrok in our labs and we did not find any issue.
    I kindly ask you to double-check if either hostname and port were not correct. Or perhaps the IP address changed? Thanks!

    #32848
    Avataracro
    Participant

    Create a tunnel: /ngrok tcp 3389

    Go to http://localhost:4040/status to see the status

     

    enter image description here

     

    Connecting from client:

    enter image description here

     

    I’m asked to login:

    List item

    But I cannot access. I’m using the same login as to ngroks dashboard but Im not getting in. What login did you use?

    Shall I use some other login information? Or can I access my login information from ngrok somehwhere?

    #32851
    AvatarCarin
    Participant

    Hi acro,

    To log in to NoMachine you must use credentials of a system account you have on that host, not the ngrok dashboard credentials.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.