User Login with private key file

Forums / NoMachine for Linux / User Login with private key file

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2401
    Avatarsunshineh
    Participant

    Hi,

    I have an Ubuntu 12.04 server. For my root login with nomachine I have to include my created keyfile.

    Now I have created a new user with ubuntu (username + password). When I login with nomachine as my new user, I only get the message

    “Authentication failed for user …”.

    I changed nothing in the server configure settings form nomachine and my key file is ther includes, too.

    What can I do?

    #2442
    Avataradp
    Participant

    Hello,

    Could you please reiterate, step by step, what you are doing to get the error message? From your post I understand that you have been successfully logging in as root to your machine using key authentication. Then you’ve created a new user (let’s call him USER1). Should this user authenticate using his username and password instead of the key or do you want USER1 to be authenticated also via key? In any case, please clarify the following:

    1) Are you using NX protocol or SSH protocol?

    2) Have you set proper authentication method in NoMachine GUI (Key or Password)?

    3) In the case of key authentication – have you pointed NoMachine to the appropriate private key (the one for USER1). Have you put the public part in the appropriate place on the host?

    Attaching (or send to ¬†issues[at]nomachine.com if file is large) log files from both sides of the connection would also be helpful to us. Please remember to set in Player’s settings to not delete logs (Setting -> Appearance -> Don’t delete old log files on exit), reproduce the issue and on the client side:

    <your_home_dir>/.nx   <РCompress this directory and send it to us

    On the server side:

    /usr/NX/var/log <– Compress this directory and send it to us.

    Thank you.

    #2454
    Avatarloic
    Participant

    Check the cert file from the nx user. maybe you can make a conclusion with the cert file from root. Maybe you must include something to the file to get access.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.