Using NoMachine with a custom keyboard layout

Forums / NoMachine for Linux / Using NoMachine with a custom keyboard layout

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #38948
    sygi
    Participant

    I have a custom keyboard layout stored in /usr/share/X11/xkb/symbols/sygi (both on the server and the local machine, which both are physical Linux machines). When using either of these machines, I can change the keyboard layout via setxkbmap sygi.

    When connecting with NoMachine (7.9.2) (with ssh authentication), I am able to change layout to the standard ones (eg. setxkbmap fr), but when running setxkbmap sygi -v -v -v -v, I get:

    `
    Setting verbose level to 8
    Setting verbose level to 9
    Setting verbose level to 10
    locale is C
    Warning! Multiple definitions of keyboard layout
    Using command line, ignoring X server
    Trying to load rules file ./rules/evdev…
    Trying to load rules file /usr/share/X11/xkb/rules/evdev…
    Success.
    Applied rules from evdev:
    rules:      evdev
    model:      evdev
    layout:     sygi
    Trying to build keymap using the following components:
    keycodes:   evdev+aliases(qwerty)
    types:      complete
    compat:     complete
    symbols:    pc+sygi+inet(evdev)
    geometry:   pc(pc104)
    Error loading new keyboard description
    `

    Any idea what I could try? I made sure that the layout file is present when connecting through NX.

    #38978
    fra81
    Moderator

    Hi,

    NoMachine doesn’t load the keymaps from the system path (/usr/share/X11/xkb), but it ships its own keyboard config files in /usr/NX/share/X11/xkb. You can try to add the layout file there.

    #39023
    sygi
    Participant

    This works, thanks a lot!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.