Verify GPU encoding used?

Forums / NoMachine for Linux / Verify GPU encoding used?

Tagged: 

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #32061
    AvatarColeman
    Participant

    Hello,

    I’m trying to determine if hardware accelerated encoding is in use on my machine. The hardware supports it, and I am getting an h.624 connection, but the CPU use in htop seems a bit high to me. The posts that I’ve found from a few years ago about this refer to log files that no longer appear to be written in the current versions.

    It is enabled in my settings, but there’s no indicator that it’s actually in use.

    So, how can I check this now?

    Thank you!

     

    #32106
    Avatarfisherman
    Moderator

    On the Linux server you can also check the session files in /usr/NX/var/log/node/C-*

    As well you can check by executing:

    grep -i encod /usr/NX/var/log/node/C-*/session

    #32107
    Avatarfisherman
    Moderator

    Please check this new feature implemented in the version 7 https://www.nomachine.com/FR04R03973.

    #32108
    AvatarColeman
    Participant

    That’s actually what I was referring to when I found old posts mentioning a way to check. Maybe I don’t have the logging enabled for that, but I don’t have a node subdirectory in /usr/NX/var/log. Since the posts were a few years old, I started thinking that the log information was moved elsewhere, but none of the files in the log directory has anything like that. On my install, the only subdirs off that are “archives” and “logrotate”.

    I did find that post you linked as well. So, one thing about that particular item, it doesn’t say where in the UI that information is located. My server version is 7.1.3 but I’ve just noticed that I think my client is rather outdated (it was kind of tricky to find something that showed the client version, at least on Windows). If my older client (I think it’s 6.4.6) is able to display the string properly, than I am on all software, which I’ll have to figure out. I’ll update my client and see if that changes what I’m seeing in the connection information. I’m assuming I’m looking in the right place (Display Settings on the client; it’s the only place that has a string that looks like the information mentioned in the KB article).

    Thanks!

    #32115
    Avatarfisherman
    Moderator

    About /usr/NX/var/log/node folder please check on the server side.

    About Feature implemented I mentioned in a previous post, you need to update your client to the latest version 7.
    Information about used codec will be displayed in Display settings and Connection information.

    #32126
    AvatarColeman
    Participant

    “/usr/NX/var/log/node folder please check on the server side.”
    The server doesn’t have it.

    jason@CB5:/usr/NX/var/log$ du -a .
    4 ./logrotate
    4 ./archives
    40 ./nxupdate.log
    12 ./nxd.log
    44 ./nxinstall.log
    28 ./nxerror.log
    16 ./nxserver.log
    152 .

    I did upgrade my client and I can see the string now, and it is indicating that I’m not getting h.264 acceleration, so I’ll have to figure out why that is.
    Thanks!

    #32201
    AvatarColeman
    Participant

    About /usr/NX/var/log/node folder please check on the server side.

    I finally found the session logs, per https://www.nomachine.com/FR11Q03892

    As of version 7.0.208: The display agent log files should be stored in the correspondent session directory created under the home directory of the session owner, e.g. the user’s home/.nx/node/C-display-sessionid directory. Which is where my session logs are.

    The session log is verifying (in addition to the client information) that I am getting only the software encoder, though I still have no indication why.

    Thank you

    #32211
    Avatarfisherman
    Moderator

    In order to understand why GPU encoding is not in use, can you provide us with following information:
    – GPU card on the server side
    – GPU drivers used
    – Session log file

    #32222
    AvatarColeman
    Participant

    Certainly!

    The server host is an Intel gen5 (Broadwell) processor, using the integrated graphics.

    lspci:
    00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics [8086:1606] (rev 09) (prog-if 00 [VGA controller])
    DeviceName: VGA compatible controller
    Subsystem: Intel Corporation HD Graphics [8086:1606]
    vainfo:
    libva info: VA-API version 1.8.0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
    libva info: Found init function __vaDriverInit_1_8
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 1.8 (libva 2.8.0)
    vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics – 20.2.0 ()

    Session attached.

    Attachments:
    #32234
    Avatarfisherman
    Moderator

    Please can you check if libva-drm2 is installed on your host?

    #32238
    AvatarColeman
    Participant

    It is:

    apt search libva-drm2
    Sorting… Done
    Full Text Search… Done
    libva-drm2/groovy,now 2.8.0-1 amd64 [installed,automatic]
    Video Acceleration (VA) API for Linux — DRM runtime

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.