Version 6.10.12 breaking disk sharing?

Forums / NoMachine for Mac / Version 6.10.12 breaking disk sharing?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27686
    Avatartom5
    Participant

    Hello,

    Has anyone had any issues with 6.10.12 breaking disk sharing?

    Disk sharing was working fine prior to upgrading and then stopped working on all upgraded systems.  Red circle with exclamation mark ‘Failed to connect the disk XXXX.  The directory XXX doesn’t exist’

    As a test I uninstalled NoMachine Enterprise Desktop on one workstation and did a fresh 6.9 install with default node and server config files.  I could then share a disk with this Enterprise Desktop.  Updating the same Enterprise Desktop to 6.10.12 with no other changes stopped disk sharing from working to that ED.  Error as above.

    I also tried coping the default server and node config files to another 6.10.12 Enterprise Desktop and I got the above error.

    Happens whether its a direct connection to the ED or through the Cloud Server.

    Thanks.  Tom

    #27724
    Avatartom5
    Participant

    No change to this following the updated package provided by Britgirl, unfortunately.

    The issue appears to be with the Enterprise Desktop/server rather than the client package.   And specifically with the Mac version.

    With client 6.10 (PC and Mac), I can connect a disk to a default install of 6.9 ED Mac but not to a default 6.10 ED Mac

    With client 6.10 (PC and Mac), I can connect a disk to a 6.10 Cloud Server (PC)

    I hope that helps.  Tom

    #27740
    Avatartom5
    Participant

    I’ve got this working now.  I found if I completely uninstalled Enterprise Desktop, removed ‘nxnode’ and ‘NoMachine’ from the various tabs in System Preferences > Privacy, restarted the computer, and did a full reinstall with 6.10 it started working again.

    Must be something to do with the Privacy section of Mac OS X.  The audio wasn’t working either (on all 17 test machines).  I tried unchecking, restarting, rechecking these items etc. but couldn’t get it working without a full reinstall.

    Nearly there now!  Tom

    #27751
    AvatarBritgirl
    Keymaster

    Hi, this is actually a known problem and uninstalling and reinstalling is the workaround.

    Audio and disk sharing stop working after automatic updates to v. 6.10.12
    https://www.nomachine.com/TR05R09708

    Glad to know it’s working now 🙂

    #27753
    Avatartom5
    Participant

    Ah! Thanks Britgirl!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.