Version `XCRYPT_2.0′ not found required by /lib/x86_64-linux-gnu/

Forums / NoMachine for Windows / Version `XCRYPT_2.0′ not found required by /lib/x86_64-linux-gnu/

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #36393
    harrisromeo
    Participant

    Hi all, I’m trying to launch paraview using the NoMachine option. I am using Ubuntu 20.04.

    I just built using the ‘nomachine’ option as I don’t have a graphics card system. I tried launching paraview but I get the following messages:

    paraview: /home/harrisromeo/utilities/NX/lib/libcrypt.so.1: version `XCRYPT_2.0’ not found (required by /lib/x86_64-linux-gnu/libkrb5.so.26)

    paraview: /home/harrisromeo/utilities/NX/lib/libcrypt.so.1: version `XCRYPT_2.0’ not found (required by /lib/x86_64-linux-gnu/libroken.so.18)

    Please how can I fix this.

    #36397
    graywolf
    Moderator

    ParaView is searching for libraries at a wrong path (/home/harrisromeo/utilities/NX/lib). Please check how LD_LIBRARY_PATH and LD_PRELOAD are set in your environment.

    #36399
    harrisromeo
    Participant

    Hello graywolf,

    The library path that it is searching is the one created after building the nxserver binaries.

    Even in my “usr/lib/x86_64-linux-gnu path”, “libcrypt.so.1” is the only version there.

    I think it has got to do with how Ubuntu (I use 20,04) names the libcrypt.so file.

    Some online sources believe libcrypt.so.1 is actually version 2, that on Archlinux, it was explicitly named version 2.

     

     

    #36402
    graywolf
    Moderator

    PAraView wouldn’t get any problem if it weren’t searching that path for libraries. That should not happen, so I told you to check LD_* in the environment.

    #36436
    harrisromeo
    Participant

    Hello graywolf,

    I have set my LD_PRELOAD path to my “user/lib/x86_64-linux-gnu” folder as against the one built by ‘nomachine’ in my “/home/harrisromeo/utilities/NX/lib/” folder.

    My LD_LIBRARY_PATH has also been set as shown in the attachments.

    I now get the initial error of graphics card to run OpenGL/Mesa (which led me to ‘nomachine’ option in the first place) and also a libc.so.6 stack trace of the error.

    Please I really need a way out of this problem. I have also attached a picture of the error.

    #36445
    graywolf
    Moderator

    You can setup VirtualGL by the command sudo /home/harrisromeo/utilities/NX/bin/nxserver --virtualgl-install.

    Then run paraview with VirtualGL assistance: /home/harrisromeo/utilities/NX/scripts/vgl/vglrun paraview

    #36452
    harrisromeo
    Participant

    Hello graywolf,

    Kindly find attached the new error flags related to OpenGL rendering context obtained on X  server.

    I have also attached my display environment for display connection with xserver

    #36457
    harrisromeo
    Participant

    I should also re-iterate that I have no graphics card on my system.

    Thanks

    #36472
    graywolf
    Moderator

    VirtualGL is of little use if your system has no video card.

    You should not set $HOME/utilities/NX/lib in LD_LIBRARY_PATH, I don’t get the reason for setting DISPLAY=:0.0.

    If you want to run a virtual display and you have a free version of NoMachine, turn off the display manager (systemctl stop display-manager), set CreateDisplay and DisplayOwner in /usr/NX/etc/node.cfg, restart the NoMachine server (nxserver --restart).

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.