Very slow with Xubuntu 20.04

Forums / NoMachine for Linux / Very slow with Xubuntu 20.04

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #33315
    Britgirl
    Keymaster

    bobnx, NoMachine works out-of-the-box with a huge number of stock distros, including Xubuntu. The problem is related to the specific combination of graphics card and drivers as Fra81 said. So there’s not much we can do.

    NX always worked previously

    We were not able to reproduce this problem, you could go back to using the earlier version of Xubuntu. Or with this comment are you referring to our legacy product NX Free Edition (up to 3.5) maybe? The functionality of that product is available in the NoMachine Workstation product.

    #33314
    commandline
    Participant

    Hey @bobnx no worries, happy with the replies.

    [removed] I’m using gdm3 with lxqt-desktop. This works very well and is the only desktop working well on Ubuntu.

    NoMachine showed 100% CPU usage yesterday, not today for the entire day. However, it now no longer copy-pastes passwords on login screens. This is mindblowing stuff.

    #33317
    bobnx
    Participant

    As I have said, I have tried 2 different video drivers – the default open source driver and the Nvidia propriety driver with the same results.

    It was working with Xubuntu 18.04 and to the best of my recollection it was with the latest NX (perhaps a few “point” versions old).  I.e. the same “generic” version of NX on 18.04 and 20.04

     

     

    #33338
    bobnx
    Participant

    Update :

    Xubuntu/Ubuntu pushed some updates to 20.04 this weekend.  One of the updates I noticed involved Lightdm.  So I did a check and there was still a problem.  But I thought let us be thorough, so I uninstalled the Nvidia driver and re-installed the default OpenSource drive.

    It works!

    I just did a reboot to confirm and yes it still works.

    I suppose I should re-check with the Nvidia driver and will do it when I have time.

    It should be noted I did check with replacing the Nvidia driver previously, and it did not work.  So the Ubuntu changes to Lightdm must also be required.

    #33349
    Britgirl
    Keymaster

    It would seem that updates of Xubuntu fixed whatever the problem was in the first place with your affected host, so that’s good news.


    @commandline
    , I suggest you check your other topic https://forums.nomachine.com/topic/nxclient-bin-high-cpu-load-100-ubuntu-20-04-lts and add comments related to CPU usage there, and not here. If you have a copy and paste problem, please open a new topic.

Viewing 5 posts - 16 through 20 (of 20 total)

This topic was marked as solved, you can't post.