Video in floating mode (disable x11 vector graphics)

Forums / NoMachine Terminal Server Products / Video in floating mode (disable x11 vector graphics)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26802
    Avatargaranha
    Participant

    Hi,

    We are currently assessing the implementation of NoMachine Terminal Server  as a way to expose Linux applications to Windows environments.

    We installed the RPM in CentOS and were able to connect to the server with a custom session in floating mode. However the performance showed to be pretty laggy and with poor quality. The server was located in our datacenter (same building) and we were accessing with NoMachine through wifi.

    Now that we’re currently all working from home, we have to access through the internet + vpn. In this case, the performance is totally unusable.

    We then tested the custom session with “virtual desktop” and the quality and responsiveness was excellent.

    After some research I found this in your documentation:

    “Enable/disable the X11 vector graphics mode by means of the <b>Use X11 vector graphics mode for virtual desktops</b> option. This applies only to virtual desktops and custom sessions running in a virtual desktop. Note that custom sessions running in a floating window are always in X11 vector graphics mode. X11 vector graphics mode can instead be disabled/enabled for custom sessions running in a virtual desktop.”

    Are there any plans to implement full video in floating? I don’t believe we can go through with X11 vector graphics because of poor performance and we really need the floating functionality so the applications can be fully integrated in a windows desktop.

     

    Best regards

    #26847
    Avatargraywolf
    Moderator

    Hello.

    Had you turned X11 vector graphics off when trying the custom virtual desktop (in node.cfg: AgentX11VectorGraphics 0)? I’m asking as I’m not sure that is relevant.

    Have you notice abnormal increase of network usage in floating window mode?

    Could you describe the problem you see? Is it laggy in response to a specific user interaction? Is quality poor because images are blurry, text badly rendered or what? Which applications are you trying in floating window mode?

    #26849
    Avatargaranha
    Participant

    Hi!

    I’ve tried to disable AgentX11VectorGraphics with no success. Only customsession+virtual desktop works very well.

    The applications I’m testing are spyder for python development, rstudio and vscode so far. I’ll also need stata in the feature but haven’t tested it yet.

    With floating the image is blury, and navigating the menus is extremely slow. Text input and selection is also very laggy. I also get bad render with vscode and sometimes rstudio (spyder is the one that works best, but still not usable).

    I’m a bit confused with the documentation: is it possible to use full video (like h.264) in floating custom session or not?

    Best regards

    #26916
    Avatargraywolf
    Moderator

    H.264 is used in floating window mode to draw those parts of screen that are not built with vector graphics (images, video).

    You can search for client log files in your home folder: they have a path like .nx\R-…\session. If you find that session log contains this line, you can say H.264 is in use:

    Info: Using H.264 hardware decoder.

    Would you send logs for the two cases? Check “Don’t delete log files on exit” in client Privacy settings to be sure they are retained.

     

    #26970
    Avatargaranha
    Participant

    Thanks for the reply graywolf,

    My question is if it is possible to run floating without any vector graphics, just video (vp8, h.264, mpeg, whatever).

    With vector graphics through VPN we will not get a good enough performance (responsiveness and quality of image) specially because most recent applications use X11 very inefficiently, constantly redrawing the window (VSCode, RStudio, Spyder, etc.).

    Best regards

    #26981
    Avatargraywolf
    Moderator

    It is not possible to run floating window without any X11 graphics, but I think it wouldn’t make much difference: if I got that right, you have good performance with virtual desktop mode no matter the value of X11VectorGraphics. With X11VectorGraphics “1”, the use of vector and video graphics is the same in both virtual desktop and floating window.

    May I ask you to :

    1. Set X11VectorGraphics “1”
    2. Enable debug mode in server: sudo /etc/NX/nxserver --debug --enable
    3. Check “Don’t delete log files on exit” in client Privacy settings
    4. Run a test in “virtual desktop” mode
    5. Collect statistics: Ctrl+Alt+0, Connection pane, get stats
    6. Repeat steps 4 and 5 for “floating window” mode
    7. Collect server logs: sudo /etc/NX/nxserver --debug --collect
    8. Collect client logs: zip the folder %USERPROFILE%\.nx

    Please send results (client log, server log, virtual desktop stats, floating window stats) to: forum (at) nomachine (dot) com

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.