Virtual desktop in free version?

Forums / NoMachine for Linux / Virtual desktop in free version?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21202
    Avatarrahvee
    Participant

    Running NoMachine on RHEL 7 / Centos 7, the remote desktop connects to the server console. I saw the checkboxes for blanking the physical console (but it didn’t work) and also the automatic sizing of the desktop didn’t work – I’d really just prefer to have a virtual desktop, not touching the physical console at all.

    Are the commercial versions the only versions that allow creation of a virtual desktop? Can I get a virtual desktop with the free version?

    #21216
    Avatarkroy
    Contributor

    I saw the checkboxes for blanking the physical console (but it didn’t work)

    Is that a virtual machine? You need to know that blanking features applies only for physical monitors.

    The NoMachine virtual desktop functionality is available on remote Linux host with Workstation, Small Business Server, Terminal Server, or Enterprise Terminal Server.

    However, NoMachine is able to use its own display service (that is an embedded X server) to let users connect seamlessly a physical desktop running in background on the remote machine when that Linux host doesn’t have an X server running (e.g. a headless machine).

    To disable Xserver you can for example use sudo init 3 command. After disabling Xserver – nxserver restart is needed (sudo /usr/NX/bin/nxserver --restart).

    #21223
    Avatarrahvee
    Participant

    Thank you for your response – Yes, it’s a virtual machine. Your response was almost great… I switched to multi-user.target (analogous to init 3) and restarted. Connect to NX. Sure enough, the local console is just a text login prompt, and NX creates its own X server (Great!!!) … but … My desktop is weird… Some of the gnome components are missing, like the menu in the upper left, and “Places.” For some purposes, it’s usable, but it’s not the normal expected experience… I selected the option for automatically resize session to match local (doesn’t work), and while I’m connected, I can’t make the Nomachine menu items appear (peel-back upper right corner) can’t seem to enter full-screen mode or resize…

    Server is RHEL 7.

    #21233
    Avatarkroy
    Contributor

    It looks like you’re using Gnome 3D, but you prefer Gnome Classic. Just edit the /usr/NX/etc/node.cfg file, find and change line with DefaultDesktopCommand key to:

    DefaultDesktopCommand "env GNOME_SHELL_SESSION_MODE=classic gnome-session --session gnome-classic"

    as it’s in the article: https://www.nomachine.com/AR10N00906.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.