Virtual session doesn’t match client resolution

Forums / NoMachine Terminal Server Products / Virtual session doesn’t match client resolution

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33332
    Avatarherouth
    Participant

    Hello,

    I have a Linux laptop with NoMachine Workstation, to which I connect from an iMac using the free NoMachine client.

    The iMac has two monitors – its own retina display, and a secondary 4k Dell display.

    The reason I bought NoMachine Workstation is because it has the option to open virtual desktops that are supposed to match the number and resolution of the client monitors.

    This client is capable of displaying dual 4k output. I know this because I have a different connection – a remote Linux with a physical desktop of two 4k monitors, and it connects and shows the resolution correctly using “fullscreen on all screens”.

    However, when I connect to the NoMachine Workstation using a virtual desktop, I get only 5120×1440 (using “resize remote display” and “fullscreen on all screens”. This is bad because the display is actually scaled, making fonts blurred and hurting my eyes.

    When I go to the server settings, it only allows up to 5120×1440. If I use a custom resolution of 7680×2160, it switches to “viewport mode” and also cancels one monitor and thinks it only has a single monitor.

    The version of Linux I am running is Linux Mint Ulyssa, which is based on Ubuntu 20.04. The desktop is Cinnamon.

    I tried to edit node.cfg and set a minimum and a maximum resolution of 7680×2160. The setting is ignored, though I restarted the server.

    I tried to change the encoding from H264 to VP8 or MJPEG. It didn’t help.

    The Linux laptop has 32Gib of memory.

    How do I make it display two monitors of 4k resolution each – or properly match my Mac monitors?

    #33599
    AvatarTor
    Contributor

    Hi. Could you send here the output of the command xrandr -q executed in a terminal on the virtual desktop?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.