VirtualGL on CentOS 8

Forums / NoMachine Terminal Server Products / VirtualGL on CentOS 8

This topic contains 5 replies, has 2 voices, and was last updated by Avatar kimmejas 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #24043
    Avatar
    kimmejas
    Participant

    Hi,

    I’m currently evaluating a copy of NoMachine Workstation 6.8.1 on a new centOS 8 machine. After experiencing slow performance of the GNOME shell in virtual desktop sessions, I followed the instructions here (https://www.nomachine.com/AR01Q01012) to enable virtualGL.  Having proper openGL performance is important since the machine is expected to host CAD/CAM applications that require hardware acceleration.

    Unfortunately, now the session crashes immediately upon login with the error “The connection to the server was shut down”. Looking at the logs, it doesn’t look like VirtualGL is playing nicely with gnome:

    Oct 16 14:11:23 ro2-apollo dbus-daemon[4281]: [session uid=1010 pid=4277] Activating service name=’org.freedesktop.systemd1′ requested by ‘:1.3’ (uid=1010 pid=4152 comm=”/usr/libexec/gnome-session-binary –session=gnome “)
    Oct 16 14:11:23 ro2-apollo dbus-daemon[4281]: [session uid=1010 pid=4277] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1
    Oct 16 14:11:23 ro2-apollo gnome-session[4152]: No protocol specified
    Oct 16 14:11:23 ro2-apollo gnome-session[4152]: [VGL] ERROR: Could not open display :0.
    Oct 16 14:11:23 ro2-apollo gnome-session[4152]: No protocol specified
    Oct 16 14:11:23 ro2-apollo gnome-session[4152]: [VGL] ERROR: Could not open display :0.
    Oct 16 14:11:23 ro2-apollo gnome-session[4152]: gnome-session-binary[4152]: WARNING: software acceleration check failed: Child process exited with code 1
    Oct 16 14:11:23 ro2-apollo gnome-session-binary[4152]: WARNING: software acceleration check failed: Child process exited with code 1
    Oct 16 14:11:23 ro2-apollo gnome-session[4152]: Unable to init server: Could not connect: Connection refused
    Oct 16 14:11:23 ro2-apollo journal[4474]: Cannot open display:

    Has anyone seen this issue before, or have some suggestions for how to fix it?  Please let me know if any additional information would be helpful.

    Thanks!

    #24050
    Avatar
    graywolf
    Moderator

    [VGL] ERROR: Could not open display :0.

    That is, the DISPLAY :0 is not accepting localhost connections. That is required for VirtualGL to offload the 3D operations to the display :0 (actually using the video card).

    Follow this article to check the VirtualGL setup:

    https://www.nomachine.com/AR05P00982

    Have you got any warning message when you run sudo /etc/NX/nxserver --virtualgl-install ?

    #24052
    Avatar
    graywolf
    Moderator

    It looks specific to CentOS8. This Trouble Report provides a workaround: https://www.nomachine.com/es/TR08Q09375

    #24055
    Avatar
    kimmejas
    Participant

    Thanks for your help.  I followed the linked instructions to install lightdm, and that allowed me to connect to the session. Unfortunately now I see only a black screen.

     

    Oct 17 12:11:27 ro2-apollo org.gnome.Shell.desktop[17694]: failed to create drawable
    Oct 17 12:11:27 ro2-apollo org.gnome.Shell.desktop[17694]: [VGL] ERROR: in OGLDrawable–
    Oct 17 12:11:27 ro2-apollo org.gnome.Shell.desktop[17694]: [VGL]    84: Could not create Pbuffer
    Oct 17 12:11:27 ro2-apollo gnome-session[17275]: gnome-session-binary[17275]: WARNING: App ‘org.gnome.Shell.desktop’ exited with code 1
    Oct 17 12:11:27 ro2-apollo gnome-session-binary[17275]: WARNING: App ‘org.gnome.Shell.desktop’ exited with code 1
    Oct 17 12:11:27 ro2-apollo org.gnome.Shell.desktop[17728]: failed to create drawable
    Oct 17 12:11:27 ro2-apollo org.gnome.Shell.desktop[17728]: [VGL] ERROR: in OGLDrawable–
    Oct 17 12:11:27 ro2-apollo org.gnome.Shell.desktop[17728]: [VGL]    84: Could not create Pbuffer
    Oct 17 12:11:27 ro2-apollo gnome-session[17275]: gnome-session-binary[17275]: WARNING: App ‘org.gnome.Shell.desktop’ exited with code 1
    Oct 17 12:11:27 ro2-apollo gnome-session[17275]: gnome-session-binary[17275]: WARNING: App ‘org.gnome.Shell.desktop’ respawning too quickly
    Oct 17 12:11:27 ro2-apollo gnome-session-binary[17275]: WARNING: App ‘org.gnome.Shell.desktop’ exited with code 1
    Oct 17 12:11:27 ro2-apollo gnome-session-binary[17275]: WARNING: App ‘org.gnome.Shell.desktop’ respawning too quickly
    Oct 17 12:11:27 ro2-apollo gnome-session-binary[17275]: Unrecoverable failure in required component org.gnome.Shell.desktop
    Oct 17 12:11:27 ro2-apollo gnome-session[17275]: Unable to init server: Could not connect: Connection refused
    Oct 17 12:11:27 ro2-apollo journal[17768]: Cannot open display:

    #24076
    Avatar
    graywolf
    Moderator

    Now connection to :0 succeeded but an OpenGL error is issued.

    Is Xorg on display :0 using an NVIDIA or AMD video card? Is the proprietary driver installed (the one provided by the video card manufacturer) rather than the open source one?

    #24111
    Avatar
    kimmejas
    Participant

    The display is using an Nvidia card (Quadro RTX 4000) with proprietary driver version 430.50.

    I noticed it was crashing when trying to launch a session on the physical display as well, so I reinstalled the nvidia driver and that appears to have resolved the issue.  I now see the GPU when connecting via nomachine and it appears to be working.

    The only issue I see now is that it can’t launch nvidia-settings as it fails with “ERROR: Unable to load info from any available system

    Thanks for your help!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.