vsync and tearing

Forums / NoMachine for Linux / vsync and tearing

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36975
    Sharft 6
    Participant

    Hi there. I’m running NoMachine server on ubuntu 20.04 with Ubuntu and Windows clients. Using the nvidia 495.46 proprietary driver on the server.

    The main problem I’m having is with tearing. it looks great if I connect to NoMachine, then play a tearing test video of simple black and white bars. However if I try something a bit more demanding e.g. a full screen video with colour, within a few seconds of video playback, tearing begins. If I then pause the video and go back to the simple black & white tearing test, it looks torn to pieces. To recover from this I must end the NoMachine client session and then re-connect.

    Something is changing when playing videos in full screen which causes severe tearing which persists until the session is ended. Any idea what it could be?

    #36998
    fra81
    Moderator

    Hi,

    what you describe is likely a driver issue. Just to exclude a possible culprit, please try to disable hardware encoding on the server (Server preferences -> Performance) and see if the issue persists.

    If disabling hardware encoding doesn’t help, it would be nice to take a look at the logs. You can gather them following the instructions in https://knowledgebase.nomachine.com/DT11R00182 and send to forum@nomachine.com.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.