WebRTC issues – NAT – infinite looping

Forums / NoMachine Terminal Server Products / WebRTC issues – NAT – infinite looping

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29687
    AvatarFrancis
    Participant

    Hello,

    We are evaluating the NoMachine enterprise edition and we are not able to make WebRTC work from outside our network regardless the browser. After the user logs and choose to create a new virtual desktop, the process is just spinning up.

    We are able to reproduce the behavior everytime regardless the topology (single node or multi-nodes).

    We have setup a LAB for the current issue. The LAB consist of :

    • 2x Centos7.8 servers with nomachine-enterprise-terminal-server_6.11.2_1 on a private network;
    • The two Enterprise Terminal Servers will be use as nodes on which virtual desktops will be running.
    • We ports forwarded 1024 to 65535 to the shared IP (only during the tests, we know it is dangerous).
    • We deactivate firewalls on both servers.

    We have made the following modification in server.cfg as proposed by https://www.nomachine.com/AR07N00894

    •  AcceptedWebMethods classic,webrtc
    • Section “STUN”
    • Host      stun1.l.google.com
    • Port      19302
    • EndSection

    FYI the two servers can do STUN requests (stun-client -v stun1.l.google.com:19302).

    If a websession on a Windows PC is start on the same private network, WebRTC is working fine as expected (next image)

    And a look at the nxwebplayer logs shows us that everything seems looking fine.

    The same Windows PC connected on my mobile phone (roaming), WebRTC is just spining up (next image)

    And a look at the nxwebplayer logs show us a WebPingMEssage infite looping.

    What are we missing up?

    Thank in advance!

    #29690
    AvatarBritgirl
    Keymaster

    Please send images and any other attachments to forum[at]nomachine[dot]com. Thanks!

    #29692
    AvatarFrancis
    Participant

    Done!

     

    thanks again!

    #29720
    AvatarShoti
    Contributor

    Hi Francis,

    Unfortunately, we never can guarantee, that public STUN/TURN servers will work, it could be overloaded and/or can have some other issues, it’s out of our scope and we provide it just as an example in our AR.

    In the same article, there’s an instruction on how to configure servers using a Coturn project (https://github.com/coturn/coturn). We successfully tested the same case in our lab using STUN/TURN servers configured by Coturn.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.