White screen after first connect since v8

Forums / NoMachine for Linux / White screen after first connect since v8

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #40212
    Coleman
    Participant

    Hello,

    I’m running NoMachine on a Intel based laptop using h.264 hw accel. This past week I saw the update prompt to go to version 8, which I accepted. Since then, there’s a really strange behavior- I can only connect and see the desktop one time. After I disconnect, when I try to connect again later, the connection goes through, but I only receive a white screen.

    If I restart the NoMachine service, I am able to connect again fine, but again, only one time. The machine is running Manjaro, and the update to NoMachine shows 8.0.168.

    I saw some old posts from around 2020 that seemed to have similar issues, which disabling client side hw decode seemed to workaround the problem, but that doesn’t appear to have any affect here.

    Thank you!

    #40219
    eugenez
    Participant

    Hello.

    I confirm of this behaviour. When connecting to a computer running Manjaro Linux with nomachine version 8.0.168-1, immediately after restarting the nxserver service, the connection proceeds normally. After disconnecting, when reconnecting, we observe a white screen, and, later, the message “connection timed out”.

    Next connection to remote desktop becomes possible only after executing “systemctl restart nxserver”.

    #40220
    shimikano
    Participant

    I’m witnessing the same behavior on Arch Linux with Intel graphics, Gnome 42.4 on X11 , physical display, NoMachine 8.0.168 installed from the AUR:

    The first connection after a server restart works fine, but any subsequent connection results in a white screen. I tried various clients, which clearly points to a server problem.

    Disabling hardware encoding on the server solves the issue.

    I also tried a fresh NoMachine DEB install on a Ubuntu live CD on the same machine and the same configuration (i.e., hardware encoding enabled). In that case, multiple successive connections work fine.

    So, I would say it’s a server configuration issue specific to Arch and hardware encoding with Intel graphics.

    #40233
    eugenez
    Participant

    Disabling hardware encoding on the server solves the issue.

    Confirm, this solution works fine.

    #40355
    fra81
    Moderator

    Hi,

    would you reproduce the issue again with hardware encoding enabled and send server side logs to forum[at]nomachine[dot]com? Please find instructions in https://kb.nomachine.com/DT11R00182.

    #40357
    Coleman
    Participant

    I have sent the requested logs in.

     

    #40428
    Coleman
    Participant

    I didn’t see a mention of it in the release notes, but 8.1.2 update that just came out seems to have resolved this problem for me.

     

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.