White window when running X11 app

Forums / NoMachine for Linux / White window when running X11 app

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #24584
    Avatarjeh2019
    Participant

    I installed NoMachine server on a Linux server ( SLES 11.4) and NoMachine client (6.8.1) on a Windows 7 PC to see if it can replace another software package that we are currently using to run a X11 app. I can log into the Linux server however when I launch X11 apps (xclock and xeyes) they run and display on the client but they are laying on top of each other and don’t appear in a window with borders so I can move them around. When I try to run my application all I get a is a white window. Any assistance would be appreciated.

    #24598
    Avatargraywolf
    Moderator

    Are you trying a Custom, Single application, Floating window session?

    Could you try a different client host (Linux, if possible) and see if you get the same result?

    #24608
    Avatarjeh2019
    Participant

    I don’t understand the first question. Where do I determine the Window session? I can’t use a different client.

    #24614
    Avatargraywolf
    Moderator

    Press Ctrl+Alt+0 in the NoMachine client, while the remote session is connected. Menu shows up, then click on Connection. Read the session type there.

    #24657
    Avatarjeh2019
    Participant

    Session Type : Physical desktop

    #24666
    Avatargraywolf
    Moderator

    So the physical screen of the server would show the same problem. Is the server headless, with display manager turned off? In such a case NoMachine would ask you if you want to create a virtual display.

    Enable verbose logging:

    /etc/NX/nxserver --debug --enable node
    /etc/NX/nxserver --debug --enable server

    Disable log cleanup in /usr/NX/etc/node.cfg:

    SessionLogClean 0

    Then connect to the remote server and reproduce the problem.
    What is the command set in node.cfg (search for DefaultDesktopCommand)? Search log file /usr/NX/var/log/nxserver.log for that command.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.