Win7 client -> Linux Ubuntu 12.04 – have to connect twice

Forums / NoMachine for Linux / Win7 client -> Linux Ubuntu 12.04 – have to connect twice

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1151
    Avatarnogero
    Participant

    I have setup a new server running Ubuntu 12.04 LTS 32bit

    NX server is version 4.0.367_6 Free

    NX Windows 7 client is 4.0.367_1 Free

    When I start NX and I ‘Connect’ to the server I get a login prompt. Then I login selecting Unity 2D for desktop, then window goes black for 5-10 seconds and it pops me back to the Connect screen with no errors displayed. Then if I click Connect again it connects OK, already logged in.

    It also seems slow at everything compared to old version 3.x that I’ve used a long time.

    Attached are log files /usr/NX/var/log and /home/…/.nx

     

    #1179
    Avatarsil04
    Keymaster

    This seems a X server reset at the login screen that is not caught by the node.

    Explanation: After the login, the X server resets and closes all the connections by clients, including the NoMachine node process. Then the X server begin listening again, so the desktop environment can start. The node should try to connect again automatically but it is mistaking the reset.

    Is this explanation correctly describing the problem? Can you please check if before and after the login screen the X server process id is still the same? You can do that using the ps command.

    On the server do:

    > ps auxwww|grep X

    Then login. After the client disconnects, do again:

    > ps auxwww|grep X

    See if the pid of the X server process has changed.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.