Windows host resolution problem

Forums / NoMachine for Windows / Windows host resolution problem

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20732
    kwarren
    Participant

    I’ll try to include as many details as I can, not sure which of them caused the problem, but this has not happened on this computer – over a 5 year period, until a few hours after having NoMachine server installed – so it seems pretty obvious it’s part of the problem. Unfortunately uninstalling NoMachine didn’t fix the problem either.

    Environment info:

    -a Windows 7 machine is the host. It has a 1080p resolution, and is connected to a 1080p monitor.

    -client: ubuntu – also 1080p resolution and monitor [probably irrelevant]

    background: I installed NoMachine and connected to the host no problem a few times.

    The problem. The host[not connected to] had a youtube video open in full screen mode, while this was going on I connected [from the ubuntu client]. This seems to have caused a major resolution problem.

    The desktop on the host now appears to be larger than 1080p, i.e. all edges of the screen are cut off / not visible. I tried restarting, checking the resolution, uninstalling NoMachine. Nothing fixes it. I can get the whole desktop to be visible only by changing the monitor so some weird auto scale mode, which pixelates the hell out of everything. Please tell me there is a solution to this! Thanks.

    Also if this is an open source project, then why does it require enabling proprietary repositories in Linux? Got to say I’m pretty sketched out by the seemingly permanent resolution destruction.

    #20748
    kroy
    Contributor

    It is difficult to find a rational reason for which NoMachine would break display and make it irrecoverable. NoMachine options allow to choose one of the possible resolutions available by the hardware during connection to physical session.

    We aren’t able to reproduce this problem. If you could show some screenshots of your system display settings, we can try to help further.

    #20751
    Britgirl
    Keymaster

    Also if this is an open source project, then why does it require enabling proprietary repositories in Linux

    Just to clarify. NoMachine’s core technology is not released under an open source license agreement. Maybe you are getting confused with an open source derivative that is shipped with the Linux distribution you are using (which we have no control of).

    If you are interested, you can see the list of open source components we release to the community in the download section: https://www.nomachine.com/opensource

    #20759
    kwarren
    Participant

    Britgirl – yes, that’s exactly what happened. Was confused by the open source page. Thanks.

    The display problem: I’ve been searching for the symptoms – it’s like pixelated and about 10% too big in every direction: it’s not 1080p 16:9 resolution anymore (even though that’s what it’s set as in the Windows display resolution settings). Some forums suggested it was a .net framework conflicting with intel graphics drivers. So I tried uninstalling .net framework versions. It didn’t help. Again though: the laptop this happened on is around 5 years old, and this has never happened, until exactly the same time a NoMachine client connected to it. Rational or not, it’s clearly the cause, one way or another, possibly due to included software / frameworks, but it definitely caused it.

    #20794
    Britgirl
    Keymaster

    NoMachine doesn’t install video drivers and doesn’t mess with frameworks. At the most, it could have triggered a problem by changing desktop resolution. But this is done using standard system APIs in a conventional way. That said, we have not been able to reproduce this very unusual behaviour with the latest version so far (both sides).

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.