Wrong keyboard layout between Windows client and Linux server

Forums / NoMachine for Linux / Wrong keyboard layout between Windows client and Linux server

This topic contains 4 replies, has 2 voices, and was last updated by Avatar knux 3 weeks, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #23403
    Avatar
    knux
    Participant

    Hi,

    After some years using (NX derivative) I wanted to give NoMachine a new try.

    I saw too many threads here about incorrect keyboard layouts. Here is my simple experience :
    – NoMachine server is installed through the .DEB package provided by nomachine.com on a fresh Xubuntu in French and French keyboard,
    – Client is a Windows 10 in French with

    French keyboard too, using the NoMachine Enterprise Client only,
    => The keyboard layout is wrong. If I type “a”, it shows “q”. The layout configured in Xfce is the French one…

    English developers really need to worry about other keyboard layouts 🙂

    #23419
    Avatar
    graywolf
    Moderator

    I assume you are connecting to the physical display (you may have installed the free version). NoMachine changes nothing on the keyboard, it simply treats raw keyboard events on the client and on the server those raw events are translated in a meaningful symbol on the basis of the current keyboard layout of your system.

    To reproduce keyboard events NoMachine uses the virtual keyboard provided by x.org. It’s possible that this virtual keyboard is set to the default US layout and not the French one.

    To check this and change it, there is another thread with the same problem:

    NoMachine keyboard switch

    #23422
    Avatar
    knux
    Participant

    Hi graywolf and thanks you for your response (and solution).

    But why do I need to change “virtual keyboard provided by x.org” settings if I use my current physical desktop with a French keyboard?

    I’m an simple user who wants to use your product… If I access this desktop using [nx derivative], it’s OK. So it’s not impossible to give your software a better user experience… Just think about it 😉

    Regards,

    #23429
    Avatar
    graywolf
    Moderator

    Thank you for the feedback. Suggestions to improve the user experience are always welcome.

    NoMachine does not change the X.org keyboard layout: we prefer not to make such a change automatically, without the user’s control. By the way, any remote user as well as any user physically sitting next to the server host can change the layout as they find more comfortable, using the configuration tools provided by the OS.

    The mentioned “virtual keyboard” is just a facility that allows NoMachine to inject input events generated by users into the remote desktop they intend to use. So “virtual keyboard” and the physical keyboard attached to the server host are treated separately and can get different settings.

    I’m assuming you didn’t experience the same problem in the other product because you used the “virtual desktop”. You can try this kind of session in the NoMachine Workstation product and you’ll find they work as expected.

    In brief, the problem is due to X.org ignoring locale settings for the “virtual keyboard”. We could think about workaround in the NoMachine software that fixed up such issue automatically, without user’s intervention.

    #23432
    Avatar
    knux
    Participant

    When I go to Xfce’s settings, it’s the french layout which is selected (global default in fact). A didn’t use a “virtual desktop” when trying the other product. That’s why I thought there was a bug or non intuitive issue.

    But for information, here is the config of the virtual keyboard:

    xkbcomp -i 5 -xkb $DISPLAY – | grep “xkb_keycodes\|xkb_types\|xkb_compatibility\|xkb_symbols\|xkb_geometry”
    xkb_keycodes “evdev+aliases(qwerty)” {
    xkb_types “complete” {
    xkb_compatibility “complete” {
    xkb_symbols “pc+us+inet(evdev)” {
    xkb_geometry “pc(pc105)” {

    Don’t know why it’s not ‘fr’ since… I’m currently use this desktop with an fr azerty keyboard ^^

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.