X264 compiling error

Forums / NoMachine for Windows / X264 compiling error

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #16624
    n8v8r
    Participant

    $ ./configure –disable-cli –enable-shared –disable-avs –disable-swscale –disable-lavf –disable-ffms –disable-gpac –libdir=”C:\Program Files (x86)\NoMachine\bin”

    $ make

    $ make install
    install -d /usr/local/include
    install -d C:\Program Files (x86)\NoMachine\bin
    /bin/sh: -c: line 0: syntax error near unexpected token `(‘
    /bin/sh: -c: line 0: `install -d C:\Program Files (x86)\NoMachine\bin’
    make: *** [Makefile:290: install-lib-dev] Error 1

    #16640
    n8v8r
    Participant

    Given up on this whole compiling thing and purchased the NoMachine AVC Pack Subscription then

    #16656
    fra81
    Moderator

    I’m going to answer in any case, as this might be useful for someone else.

    $ ./configure –disable-cli –enable-shared –disable-avs –disable-swscale –disable-lavf –disable-ffms –disable-gpac –libdir=”C:\Program Files (x86)\NoMachine\bin”

    I don’t know if you just copied and pasted here the actual command. In that case, the reason could be the use of quotation marks ”” instead of “”. Or you can try with apostrophes ‘ ‘.

    #16657
    fra81
    Moderator

    I see that the editor modified also my marks, but I think you got the point 🙂

    Alternatively, libraries can be copied to the proper folder by hand.

    #16660
    n8v8r
    Participant

    (x86) is apparently the path of the NX installation in WIN but apparently Cygwin (compiling in Win) has some issue with parsing the (). Anyways, I purchased NoMachine AVC Pack meantime.

    #16735
    Britgirl
    Keymaster

    The correct command is --bindir='"c:\Program Files (x86)\NoMachine\bin"'

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.