EddieA

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • in reply to: Intermittent loss of keyboard/mouse #25565
    AvatarEddieA
    Participant
    in reply to: Intermittent loss of keyboard/mouse #25482
    AvatarEddieA
    Participant

    Actually I hadn’t killed anything yesterday, when I reported this, so connecting again, it’s still in the same “no input” state.

    Tried mashing every single key on the keyboard multiple times.  No effect.

    Cheers.

     

    in reply to: Intermittent loss of keyboard/mouse #25479
    AvatarEddieA
    Participant

    OK, will do.

    Although I wouldn’t have thought that would have caused all keyboard and mouse actions to be blocked.  I would have unexpected “strange” results.

    Cheers.

    in reply to: Lost window controls after 6.8.1 #23791
    AvatarEddieA
    Participant

    Maybe not a NoMachine bug per se, but something changed between releases.

    That looks like it fixed it.  Thanks.

    Cheers.

    in reply to: Occasional core dump, 6.0.78. Slackware 14.2 #17739
    AvatarEddieA
    Participant

    Sent a few days ago.  Was it received.

     

    Cheers.

     

    in reply to: Occasional core dump, 6.0.78. Slackware 14.2 #17706
    AvatarEddieA
    Participant

    Backtrace and logs attached.

    Cheers.

     

    AvatarEddieA
    Participant

    Hmmm. I got an e-mail informing me of my own update to this post. But not one for yours above.

    I also got an e-mail for a reply to my other post.

    Cheers.

    in reply to: Cannot connect to Ubuntu running on ARMv7 #14547
    AvatarEddieA
    Participant

    Yep, changing the DefaultDesktopCommand worked. Plus I could back out the change I made for AR09L00814 and it still works.

    Thanks.

    Cheers.

    AvatarEddieA
    Participant

    OK, that seems to work.  Thank you.

    Cheers.

    BTW  It was pure chance I spotted this update, as I didn’t get an e-mail, despite having the “Notify me” box ticked.  Now on to reporting the issue I have with an ARM installation.  🙂

    AvatarEddieA
    Participant

    Any progress on this ??

     

    Cheers.

     

    AvatarEddieA
    Participant

    Looking at the traces I pulled from /etc/NX/nxserver and /etc/NX/nxnode, to me it looks like these are both called without the underlying PATH from root being propagating through. Aren’t these both called before startkde is invoked, which is the reason for the initial “Cannot find default environment” issue.

    Cheers.

    AvatarEddieA
    Participant

    Another update.

    Looking through some of the scripts that are executed at NX start-up, that manipulate PATH, I found:  /etc/NX/etc/nxserver.  Turning on debug for this script, I see the following where it checks the current setting of PATH:

    + test x = x

    + export PATH=/bin:/usr/bin

    Which could explain why later in the process I see this error, as mentioned above:

    /usr/bin/startkde: line 25: qtpaths: command not found

    But not why /usr/bin/startkde is not found. Strange.

    Cheers.

     

    AvatarEddieA
    Participant

    OK, one more step along this time, so beginning to make progress.

    On trying to connect, I got the “User connected” pop-up instead of the previous error, but then instead of the KDE start-up splash I just got a black screen with a simple, white, pop-up window that said:  “Could not start D-Bus. Can you call qdbus?”.

    Stopped NX, updated /usr/bin/startkde, cleared the old logs, and started NX.  Reproduced issue and collected server logs.  Attached.

    This line in one of the node logs caught my eye:  /usr/bin/startkde: line 25: qtpaths: command not found

     

    So, it looks like the $PATH from the environment is not making it into the NX start.

    I updated that line in /usr/bin/startkde to have the full path for qtpaths, and tried again.  This time, no pop-up, but again no KDE splash screen and just a black background.  I didn’t bother capturing the logs for this, as I’m sure it’s just going to show the same type of “command not found” error, but just later in the process.

     

    Cheers.

     

    in reply to: Still cannot find default environment after TR09N07188 fix #13237
    AvatarEddieA
    Participant

    Sorry, I’ve been out of town for a few days and only just saw this.

    At what point are you asking for these commands to be run, as I am not using NoMachine to connect to an existing X11 session.  I an using the option to create a session on connection as per https://www.nomachine.com/FR10L02842.

     

    This works perfectly on Slackware 14.1 with KDE 4.14.3, but not Slackware 14.2 with KDE 5.16.07.

     

    Cheers.

     

    AvatarEddieA
    Participant

    First thing I did was save off the files: /usr/NX/etc/server.cfg and /usr/NX/etc/node.cfg.  I can forward them on, if still needed.  The log directory was attached to my previous post.

    I then uninstalled NX and did an “rm -r /usr/NX” to (hopefully) remove all remnants.

    Next, I (re-)installed version 5.1.62.  Trying to connect from Windows 10, I now get this message:  Cannot run startkde.  Please ensure that the requested application is in the system PATH and that you have the appropriate credentials to execute it.

    So, I did a “find” on startkde and it threw up just one copy in /usr/bin/startkde, with permissions:  -rwxr-xr-x  And obviously, /usr/bin, is available in the PATH to all users.

    Logs an ps output captured and attached.

    Cheers.

     

Viewing 15 posts - 1 through 15 (of 28 total)