MadMartian

Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • in reply to: Port forwarding other services #27251
    AvatarMadMartian
    Participant

    Ah, that’s what I’m looking for.  For some reason I couldn’t find this feature before.

    Thank you!

    AvatarMadMartian
    Participant

    Now it is working, but there was only two things that have changed and I do these often enough anyway, so I was quite surprised to find that the context menu has started to work again.

    1. I rebooted
    2. I killed plasmashell and restarted it

    The other thing I notice is that the mouse cursor changes from my large red GNOME cursor to some small black cursor I have not seen before when the context menu activates.  It never did this when the context menu failed to present before.  I suspect this may be a conflict between GNOME and KDE because there are some GNOME processes running on my machine as well (Evolution Mail for one).

    I expect this will occur again, but this provides some additional context for troubleshooting.  Since my reboot was relatively recent I imagine some process that is not presently running on my computer could have been causing this issue before.

    in reply to: NoMachine in KDE system tray icon context menu broken #26879
    AvatarMadMartian
    Participant

    I’ve attached a short video (with microphone audio on to demonstrate mouse clicking) of the behavior for some context.

    in reply to: NoMachine in KDE system tray icon context menu broken #26877
    AvatarMadMartian
    Participant

    Seems you may be onto something…

    [jonathan@Hoth] /usr/NX/bin
    13:58:46 > file nxclient.bin
    nxclient.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-, for GNU/Linux 2.4.1, stripped

    I’m going to see if I can reinstall this using the 64-bit version.

    in reply to: NoMachine in KDE system tray icon context menu broken #26823
    AvatarMadMartian
    Participant

    I was able to inspect the environment of the nxclient.bin process (/usr/NX/bin/nxclient.bin –monitor –pid 12923) via /proc/28922/environ and came-up with this:

    SHELL=/bin/bash
    NX_VERSION=6.9.2
    NX_LOGS=/home/<redacted@0>/.nx/<redacted@1>
    NX_FEATURES=Hoth,ASUSAllSeries,Linux,Ubuntu 16.04.6 LTS,4.15.0,x86_64,4,688910336,314
    NX_SESSIONID=<redacted@2>
    USER=<redacted@0>
    LD_LIBRARY_PATH=/usr/NX/lib:
    SSH_AUTH_SOCK=<redacted@3>
    NX_MONITOR_OPTIONS=/home/<redacted@0>/.nx/<redacted@1>/options
    USERNAME=<redacted@0>
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/bin:/usr/bin:/usr/X11R6/bin
    NXDIR=/usr/NX
    PWD=/home/<redacted@0>
    NX_CONFIG=/home/<redacted@0>/.nx
    LANG=
    NX_SYSTEM=/usr/NX
    SHLVL=0
    HOME=/home/<redacted@0>
    SystemRoot=
    LOGNAME=<redacted@0>
    NX_GROUP=<redacted@0>
    NX_SESSION=/home/<redacted@0>/.nx/<redacted@1>
    NX_USER=<redacted@0>
    NX_HOME=/home/<redacted@0>/.nx
    DISPLAY=:0
    NX_ROOT=/home/<redacted@0>/.nx
    XAUTHORITY=/home/<redacted@0>/.nx/<redacted@1>/authority

    in reply to: NoMachine in KDE system tray icon context menu broken #26822
    AvatarMadMartian
    Participant

    Never mind, I skipped-over reading the “M-*”.  The log indicates an issue but doesn’t seem to log anything new when interacting with the system tray icon:

    Info: Slave server running with pid 28947.
    Info: Listening to slave connections on port 25002.
    Info: Starting NoMachine Monitor version ‘6.9.2’.
    Info: Loaded translation files for ‘English’.
    28922 28922 12:49:49 091.975 OsDetect: Setting os type to ‘Ubuntu’.
    28922 28922 12:49:49 092.019 Main: Creating a new connection monitor.
    28989 28989 12:49:49 183 nxexecPAMOpen: ERROR! PAM library not found.
    28989 28989 12:49:49 183 nxexecPAMOpen: ERROR! Error: ‘libpam.so.0: cannot open shared object file: No such file or directory’.
    28922 28922 12:49:49 343.726 ClientThread: Creating new thread.
    [04.16.20 12:49:49.428] X Error: 143 143
    Extension:    139 (RENDER)
    Minor opcode: 7 ()
    Resource id:  0x40003d3
    [04.16.20 12:49:49.428] X Error: BadWindow 3
    Major opcode: 18 ()
    Resource id:  0x40003d2
    [04.16.20 12:49:49.428] X Error: BadWindow 3
    Major opcode: 4 ()
    Resource id:  0x40003d2
    28922 28922 12:49:49 864.130 MonitorService: Enabled drag and drop feature.
    29728 29728 12:49:54 177 nxexecPAMOpen: ERROR! PAM library not found.
    29728 29728 12:49:54 177 nxexecPAMOpen: ERROR! Error: ‘libpam.so.0: cannot open shared object file: No such file or directory’.
    nx/nx,cookie=<redacted>,x11=0,slave=1,type=physical-desktop,id=<redacted>:13002

    in reply to: NoMachine in KDE system tray icon context menu broken #26821
    AvatarMadMartian
    Participant

    None of those files have even been modified in the past 4 days.

    This is some sort of GUI rendering glitch, it’s just the sort of thing that (as a programmer myself) would struggle to detect such behavior let alone log it.

    in reply to: Cannot connect, screen sharing is disabled #24247
    AvatarMadMartian
    Participant

    It was none of those three points, but I turned on debug logging for the server and found this:

    2019-10-25 01:29:14 259.343 71811 NXSERVER Get nodes sessions.
    2019-10-25 01:29:14 259.624 71811 NXSERVER Server config type: unix-remote,physical-desktop.
    2019-10-25 01:29:14 259.776 71811 NXSERVER Server config internal types: foreignDesktop,physicalDesktop,
    2019-10-25 01:29:14 259.876 71811 NXSERVER Sessions available on node localhost:4000: foreignDesktop,physicalDesktop,.
    2019-10-25 01:29:14 260.035 71811 NXSERVER Searching nodes in database.
    2019-10-25 01:29:14 260.138 71811 NXSERVER Amount of nodes in array: 1.
    2019-10-25 01:29:14 260.243 71811 NXSERVER Check session resources for nodes: localhost:4000.
    2019-10-25 01:29:14 260.569 71811 NXSERVER Session type: virtualApplicationDefault is not available.
    2019-10-25 01:29:14 260.650 71811 NXSERVER Session type: virtualRDP is not available.
    2019-10-25 01:29:14 260.749 71811 NXSERVER Session type: virtualUnixApplication is not available.
    2019-10-25 01:29:14 260.862 71811 NXSERVER Session type: virtualConsole is not available.
    2019-10-25 01:29:14 260.950 71811 NXSERVER Session type: foreignDesktop is available.
    2019-10-25 01:29:14 261.030 71811 NXSERVER Session type: virtualXdm is not available.
    2019-10-25 01:29:14 261.121 71811 NXSERVER Session type: virtualDefault is not available.
    2019-10-25 01:29:14 261.236 71811 NXSERVER Session type: virtualGnome is not available.
    2019-10-25 01:29:14 261.337 71811 NXSERVER Session type: physicalDesktop is available.
    2019-10-25 01:29:14 261.415 71811 NXSERVER Session type: customForeignMaster is not available.
    2019-10-25 01:29:14 261.512 71811 NXSERVER Session type: virtualAttach is not available.
    2019-10-25 01:29:14 261.619 71811 NXSERVER Session type: virtualDesktop is not available.
    2019-10-25 01:29:14 261.720 71811 NXSERVER Session type: virtualVms is not available.
    2019-10-25 01:29:14 261.847 71811 NXSERVER Session type: virtualVnc is not available.
    2019-10-25 01:29:14 262.018 71811 NXSERVER Session type: nxFrameBuffer is not available.
    2019-10-25 01:29:14 262.142 71811 NXSERVER Session type: physicalDesktop is available.
    2019-10-25 01:29:14 262.270 71811 NXSERVER Session type: virtualKde is not available.
    2019-10-25 01:29:14 262.404 71811 NXSERVER Session type: nxConsoleShadow is not available.
    2019-10-25 01:29:14 262.519 71811 NXSERVER Session type: nxConsole is not available.
    2019-10-25 01:29:14 262.609 71811 NXSERVER Session type: virtualCde is not available.
    2019-10-25 01:29:14 262.717 71811 NXSERVER Session type: physicalDesktop is available.
    2019-10-25 01:29:14 263.016 71811 NXSERVER Get value result for class: session is type unix-script,connections-limit,virtual-desktops-limit with value .

    I managed to resolve this by completely purging NoMachine from my system including deleting ~/.nx/ recursively, then reinstalling and it connects now.

    AvatarMadMartian
    Participant

    Both local and remote machines were installed from Ubuntu 16.04 (16.04.3 on local machine), but KDE was installed on the local machine and GNOME on the remote

    Remote Machine:

    • Kernel: 4.12.0-041200-generic
    • Distribution: Ubuntu 16.04.2
    • Window Manager: GNOME Shell 3.18.5
    • NoMachine (Client): 5.3.12-14

    I should also add I do not notice this keyboard issue with NoMachine anywhere else, just the Wine 64 + Guild Wars 2 + NoMachine combination.

     

Viewing 9 posts - 1 through 9 (of 9 total)