Matt Behar

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: Unable to get audio working 10.14 #34582
    AvatarMatt Behar
    Participant

    After loading the nxaudio kext, it never prompts to allow permission in security.

     

    marketingmac08:~ root# kextstat |grep nxau
    168    0 0xffffff7f84c9c000 0x5000     0x5000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <97 6 5 3 1>
    marketingmac08:~ root# /etc/NX/nxserver –restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.
    marketingmac08:~ root# kextutil -vvv /System/Library/Extensions/nxaudio.kext/
    Defaulting to kernel file ‘/System/Library/Kernels/kernel’
    /System/Library/Extensions/nxaudio.kext appears to be loadable (not including linkage for on-disk libraries).
    Loading /System/Library/Extensions/nxaudio.kext.
    /System/Library/Extensions/nxaudio.kext successfully loaded (or already loaded).

    in reply to: Unable to get audio working 10.14 #34569
    AvatarMatt Behar
    Participant

    I reset the permissions on both sides, but the server still does not list NoMachine as an available hardware device.

    in reply to: Unable to get audio working 10.14 #34557
    AvatarMatt Behar
    Participant

    I’ve tried to reinstall the application, but I’m not getting the prompt to approve the kernel extensions.

     

    Is there a way to force that to happen again?

Viewing 3 posts - 1 through 3 (of 3 total)