Ranger4564

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • in reply to: Maximum resolution – dual monitor #28089
    AvatarRanger4564
    Participant

    Tor,

    Thank you.

    I want to confirm the issue I brought up in this thread was resolved by having both monitors powered on.

    Once they were both on, NoMachine was able to see both, and allowed me the options I expected, and I can use each or both monitors to remote to the work machine.

    It would be nice if there was a config page that allowed me to tell NoMachine there are 2 monitors, or that the video card can handle the resolution, so the monitors would not need to remain in powered on mode… but this will work for my testing purposes.

    Thank you for your help Tor.

    in reply to: Maximum resolution – dual monitor #28044
    AvatarRanger4564
    Participant

    Just to clarify, my PC at work shows both monitors properly when I’m at the desk.

    It’s only 1 monitor when it’s a remote session. With RDP / [removed] / [removed], they use the virtual display. With NoMachine, it’s using the physical display but I don’t know why it’s not showing both displays.

    in reply to: Maximum resolution – dual monitor #28043
    AvatarRanger4564
    Participant

    Thanks Tor. That’s the problem and basis of my original question.

    I imagine Windows only allows 1 display in remote sessions. The virtual display.

    But I can’t tell if NoMachine is actually using portions of the RDP protocol which would limit it to 1 monitor, or not.

    Are you able to see more than 1 monitor, or are you only using 1 monitor in your setup?

    I need to find out how NoMachine is selecting monitors in the remote session. If it’s relying on windows RDP, then it may be a setting in a configuration file? Don’t know yet.

     

    in reply to: Maximum resolution – dual monitor #28005
    AvatarRanger4564
    Participant

    To clarify, the post 27980 from June 5 at 7:11, shows the windows display manager, while I was connected through [removed].

    Reply from today should clarify, but I just wanted to correct my statement in my reply.

    When I connect with [removed] Windows sees the monitor as a virtual monitor and capable of 5120 x 1440 (resolution of my connection, not a limit of the video card).

    When I connect with NoMachine, Windows see the monitor as the physical monitor, monitor 1 which is an NEC EA275WMi. That monitor’s native resolution is 2560 x 1440, which is what NoMachine is allowing me to use.

    Hope that all makes sense.

    in reply to: Maximum resolution – dual monitor #28002
    AvatarRanger4564
    Participant

    Yes, the screenshot was connected to the remote pc when I took that screen shot.

    I am not connecting with more than 1 software at the same time – the PC is set to only allow 1 remote connection at a time.

    Something happened, I’m not troubled to figure out what, but [removed] no longer connects properly, it is erroring out because of our DUO 2 factor authentication setup. It didn’t have any issues before today, but it’s freaking out today.

    [removed], which i use every day, connects to RDP no problem. Screenshot attached.

    NoMachine connects to RDP no problem, but it does not honor the DUO 2 factor authentication feature. Screenshot attached.

    The screenshots show Windows Display Manager under [removed] vs NoMachine remote connection.

    Thank you.

    in reply to: Maximum resolution – dual monitor #27980
    AvatarRanger4564
    Participant

    An update for my question and response.

    This is what Windows shows for remote desktop monitor – it uses a virtual monitor. This I believe is consistent.

    I am trying to get NoMachine to show 2 separate monitors, or 1 large monitor, either is OK for me.

    Thank you.

    in reply to: Maximum resolution – dual monitor #27976
    AvatarRanger4564
    Participant

    Hi Tor,

    Thank you for the response.

    Screen shots below.

    Even though I have 2 monitors at work, and 3 at home, NoMachine only sees 1 monitor at work… which I believe could be Microsoft RDP. But RDP doesn’t limit resolution to 1 monitor’s worth of pixel area, RDP allows me to use 5120 x 1440 if I connect with [removed] or [removed]. [removed] is slower. [removed] doesn’t work well with 2 screens, it’s just a flaw that won’t be fixed.

    What I’m saying is, I can see all of the real estate with other applications when I remote to work, I just can’t get NoMachine to detect either 2 monitors, or to allow the 5120 x 1440 resolution, even if it treats it as 1 monitor. See how Maximum Resolution is 2560 x 1440? And only showing 1 monitor?

    I hope that makes sense. Willing to try options if you have thoughts. I could not find any settings in windows that allow RDP to provide 2 monitors – Multimon, or Span option are really only useful for connecting with RDP to RDP.

    Thank you.

Viewing 7 posts - 1 through 7 (of 7 total)