RedLetter20

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: USB passthrough works sporadically #29997
    AvatarRedLetter20
    Participant

    Is there any update on this situation? Im not sure what to do from here. The USB passthrough is the main reason I use nomachine.

    For the last couple of days I’ve been having to carry around an old android tablet running virtualhere with an OTG cable in order to get anything done.

    in reply to: USB passthrough works sporadically #29983
    AvatarRedLetter20
    Participant

    1.  Can you please check do you have any conflicting software from those list AR04Q01027 installed on any machine?

    I do have Virtualhere installed on both machines, but it is not running at the same time. I have had virtualhere installed along side NoMachine for years and never had a problem. I also recently tried uninstalling Virtualhere and it made no difference.

     

    2. Or maybe any other heave software that consumes huge resources of CPU and/or network?

    CPU: on the client side no, on the host side I am running Solidworks, but cpu useage is still not very high, and Solidworks isnt open when I am trying to connect.

    NET: Nothing running that would consume much at all.

     

    3. Can you please check the network ping time, is it constantly below 20ms and there are no spikes upper than 200ms?

    Ping times between the 2 locations was consistently under 20ms, average was 17, with a single spike up to 22.

     

    4. Have you tried to restart both machines and try again? Does it work?

    Trouble shooting step number 1, turn it off and back on again. Yes I have tried rebooting both machines.

     

    5. What type of device you are forwarding?

    It is a 3D Connexion Space Mouse Wireless.

     

    6. If it will appear, you can collect logs and pass them to us. Collect them with an open session (with failed device forwarding). To collect logs from both sides use these articles: AR10K00697 and DT10O00163

    I believe I captured the logs correctly. I have attached them, in 2 separate ZIP files.

    in reply to: USB passthrough works sporadically #29965
    AvatarRedLetter20
    Participant

    Ok, I stand corrected. It doesn’t seem to be a VPN issue, that just seemed to have been a coincidence.

    I managed to get it to work yesterday through the VPN for hours, and now im on the local network and cant get it to connect.

    Is there perhaps a log somewhere so I can see if there are any error messages or something?

    in reply to: USB passthrough works sporadically #29954
    AvatarRedLetter20
    Participant

    1. What machine (Win on Mac) is under a private VPN?

    The Windows 10 Machine is behind the VPN, and the MacBook Pro is the Client PC.

    2. You connect with SSH or NM protocol?

    The connection is using NX on the default port 4000.

    3. Is the protocol’s corresponding port (22 for SSH and 4000 for NM), or maybe some custom, open in your VPN network?

    Port 4000 is open through the VPN.

    4. Is that always reproducible (USB forwarding does not work) if you are connected through a VPN?

    It appears to be yes. the last 2 times I was on the VPN it did not work, yet now that I’m home (no VPN) its working just fine.

    in reply to: USB passthrough works sporadically #29949
    AvatarRedLetter20
    Participant

    So I just realized its not as sporadic as I thought. the issue is USB passthrough wont work when I connect remotely through my VPN. How can I rectify this?

Viewing 5 posts - 1 through 5 (of 5 total)