Solidcore87

Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • in reply to: Google 2-factor authentication not working for NoMachine #16058
    AvatarSolidcore87
    Participant

    Was able to get it working. Loaded a backup of my pam.d folder and it’s now working. I think it was the “required” parameter in the nx Pam file.

    in reply to: Google 2-factor authentication not working for NoMachine #16011
    AvatarSolidcore87
    Participant

    Sorry about the late response. I will be collecting the log files in the next few days.

    Thank you for working with me. I really would like this working.

    in reply to: Google 2-factor authentication not working for NoMachine #15825
    AvatarSolidcore87
    Participant

    Tested with ssh and 2fa. That works fine with my google authenticator.

    I then turned off the google 2fa in nx pam file. Logged in with my username (manny) and password fine; sends me right to my desktop.

    I then turned back on 2fa in the nx pam file, tried to log in and it failed; telling me this here “authentication failed, please try again”. (Now, this is a different error then it has been telling me. Which has been “Authentication failed, please try again. When joining a domain, don’t forget to specify the username as domain\user.” This device is not part of a domain at all.)

    After the last failed login I checked the logs at “/usr/NX/var/log/nxserver.log”. Which tells me>

     

    768 2017-09-19 20:29:55 340.626  3025 NXSERVER WARNING! Process ‘/usr/NX/bin/nxexec –auth’ with pid ‘3047/3047’ finished with exit co    de 1 after 1,911 seconds.

    769 2017-09-19 20:29:55 341.362  3025 NXSERVER ERROR! Error while trying to authenticate user: manny using authentication method passw    ord. NXNssUserManager::auth returned 1

    770 2017-09-19 20:29:55 341.933  3025 NXSERVER ERROR! wrong ‘nxexec authentication’ for user ‘manny’ from ‘10.0.0.77’.

    771 2017-09-19 20:29:55 342.199  3025 NXSERVER ERROR! Sending error message ‘NX> 404 ERROR: Wrong password or Login.’

    772 2017-09-19 20:30:17 025.940  3051 NXSERVER WARNING! Cannot write to FD#8.

    773 2017-09-19 20:30:17 026.353  3051 NXSERVER WARNING! Error is: 32, ‘Broken pipe’.

    774 2017-09-19 20:30:17 026.937  3051 NXSERVER ERROR! username is not in the expected format.

    in reply to: Google 2-factor authentication not working for NoMachine #15820
    AvatarSolidcore87
    Participant

    I will test 2fa with ssh tomorrow, no .google_authenticator~

    So I notice now testing if I remove the 2fa line from the nx Pam config then I can log in fine with username/password. If I add the 2fa line back in the nx Pam I can’t log in with username/password, it errors with

    Authentication failed, please try again. When joining a domain, don’t forget to specify the username as domain\user.”

    I don’t have s domain set and only one user account on the computer.

Viewing 4 posts - 1 through 4 (of 4 total)