Xoltus

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Black Screen & Oops + rendering issues on Red Hat #18634
    AvatarXoltus
    Participant

    Hi David,

    Regarding the (missing) error messages: I had a similar issue on CentOS when I installed KVM which did not show any text. The reason was a missing font and I was able to solve it by running
    yum install dejavu-lgc-sans-fonts

    If this works, we should be able to see what Error2 says.

    Best,
    Lars

    in reply to: Wildcard cert on Terminal Server #18630
    AvatarXoltus
    Participant

    Hi *,

    I am afraid, I need to disagree with irek. At the moment, I evaluate NoMachine Terminal Server as well and I successfully set up the web interface using one certificate from LetsEncrypt. However, this cert is not a wildcard certificate.

    What errors do you get? Have you added the chain certificate as well?

    Best,
    Lars

    AvatarXoltus
    Participant

    Brilliant !

    Switching to the physical session’s protocol works like charm. Nonetheless, I will test disabling the Composite extension as well.

    Notwithstanding the above, are there some reasons why one should favor the virtual session’s protocol? If there aren’t any, I will just stick to the physical session’s protocol.

    I also added some users to the system to check the performance because they know the system’s applications better than I do. For this purpose, I installed the enterprise desktop evaluation but do I need to re-install the clients after I bought the fully licensed version of the terminal server?

    By the way, the documentation of NoMachine is impressive, I already solved many minor issues just by reading your documents.

    Best,
    Lars

    AvatarXoltus
    Participant

    Hi,

    taking a look at the statistics is a very good idea. Thank you.

    I attached two files: the statistics for a virtual desktop and the statistics for a physical desktop where both were measured using the same client as well as the same server (I uninstalled the terminal server after I got the statistics and installed NoMachine for Linux afterwards). Further, both measurements present the same workflow where I perform a pre-defined task with the problematic application, and I used your trick to cut off the time to initialize the session.

    One of the first aspects I noticed was the total time of execution. While the virtual physical was running for 104,710 ms (idle) and 494 ms (running),  I only needed 26,045 ms (idle) and 101 ms (running) to perform the tasks when using the physical desktop which is roughly four times faster.

    While being connected, the physical desktop transferred 688,354 bytes (in) and 1,684,627 bytes (out); but the virtual desktop transferred 709,795,968 bytes (in), 10,296,814 bytes (out). I would expect a session running four times longer to transfer roughly four time more data, but to me it seems like the virtual session does not scale linearly. However, I need to admit, when experiencing a slower connection I tend to click more — so, the data could be noisy.

    To me, it looks like the compression of the physical desktop is much better. The corresponding server reports a ratio of  3.811:1 and the terminal server totals at 1.260:1.

    Please feel free to take a look at the logs attached below. Do you have further ideas how to approach this problem?

     

    Best, Lars

     

    AvatarXoltus
    Participant

    I just double-checked and I can confirm that all cores idle between 2 and 5%, and also the main memory consumption is negligible. Further, XFCE is the only desktop installed which is also being started.

    This holds true for the Windows 7 client as well: Its CPUs idle while there is plenty main memory left.

    I use a ubuntu 16.04 server which is virtualized using KVM. According to lshw it is running the graphic driver qxl. But to be honest, I had never the need to manager graphic drivers on a server, hence, I just assume this is a standard setup.

    Maybe virtual sessions require a higher internet bandwidth. This  might actually cause the problem as the server is unfortunately connected to a weak uplink (and I cannot change it). Do you have any insights regarding the bandwidth requirements?

    However, the physical session is running perfectly fine, so the differences must be huge if the network is actually the cause (which really confuses me).

     

Viewing 5 posts - 1 through 5 (of 5 total)