Zenith

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • AvatarZenith
    Participant

    So I DO need to change the SessionLogLevel to 7 in the server.cfg and node.cfg files and SessionLogClean 0 in the node.cfg file?

    Also, since the update tab is under ‘Server preferences’ this still represents the player version (as well)? In that case it’s indeed version 6.9.2

    AvatarZenith
    Participant

    One small addition to my last post, what do you mean with: “with the latest NM 6.9.2 package as well” ? Just the latest version of the player? And if so, how can I check the version on the player?

    AvatarZenith
    Participant

    Do I also have to carry out these steps?:

    Step 1 – Set debug level in server.cfg
    Edit /usr/NX/etc/server.cfg, uncomment and set the following:
    SessionLogLevel 7

    If the problem affects web sessions, set also:
    WebSessionLogLevel 7

    Step 2 – Set debug level in node.cfg
    Edit /usr/NX/etc/node.cfg, uncomment and set the following:
    SessionLogLevel 7
    and:
    SessionLogClean 0

    Btw, when reinstalling NoMachine server on my Linux machine I didn’t install additional (separate) packages. I also had a ‘great’ idea last week. I borrowed my parents laptop, which is pretty new and they hardly use it. I just installed a few programs on it for them. So it’s a pretty uncompromised laptop if you understand what I mean. I installed the player on that and yet again got the same ‘Authentication’ error. So it’s not my Windows machine it seems.

    I will gather the logs on both machines like you said. The clean install of NoMachine on the Linux machine is left in it’s default configuration this time. I only have to know if I have to change the debug levels in the config file like the instructions mention on this page:

    https://www.nomachine.com/DT10O00163#1.1

    AvatarZenith
    Participant

    NoMachine works out of the box in the majority of scenarios

    I would agree, the installation process and the software seems really straight forward. And only when I try to login on my Windows machine I have a problem. I feel it must be such an easy solution, because it can’t be (this) hard… I still think it’s a wrong username or password.

    I re-installed NoMachine and everything went fine, up to the point of trying to log in on the Windows player. Again I get the error: “Authentication failed, please try again.”

     

    AvatarZenith
    Participant

    I understand you can’t provide remote support for non paying users, but I thought I’d ask. You never know 🙂
    If I would purchase the ‘NoMachine Enterprise Desktop Subscription for Linux’ for $44.50, would that entitle me to remote support?

    For now I’ll first try to re-install and see if that fixes anything. Should I install the ‘NoMachine Enterprise Client or the Terminal Server Node package’ as well? Because I think I did do that last time.

    AvatarZenith
    Participant

    In the player in Windows I can’t choose anything else then NX, there are no other options. In the server on Linux I can’t find an option to change the protocol either. Although I’m quite sure there have been more options available in the past, showing on the ‘Server status’ tab. In the box under ‘Use an IP from the list to connect to this desktop’.

    Now I also can’t even reach the login part in the player anymore:

    The connection to the server was lost.

    Error: Server is stopped

    While the server is clearly running. I restarted the server a few times to see if that fixed it, but it didn’t. I also restarted the player a few, but that didn’t fix anything either.

     

    In the auth.log file I see pam_unix entries, but nothing about ‘nx’ or pam_unix(nx:auth). The log mentions authentication failures and even ‘3 incorrect password attempts’, while like I said I couldn’t even reach the login part in the player this time…

    So I will e-mail those auth.log files (there’s also a auth.log.1), the last one contains some errors about port 22 (SSH). This is because I tried to change the port manually, since I couldn’t change the protocol.

    I also ran this command again: sudo /etc/NX/nxserver --debug --collect

    And I will add this zipped package to the e-mail as well.

    If this result in a solution, is there any change I could get some remote support? Because this is going on for more then over two months now.

    Thanks in advance

     

    AvatarZenith
    Participant

    Done! 🙂

    AvatarZenith
    Participant

    Yes sorry, I didn’t see your first reply on the second page here before sending that. In the meanwhile I replied to your last email, it was send on March the 13th at 17:08 (5:08 PM I believe). Please let me know if you have received it!

    Thanks in advance

    AvatarZenith
    Participant

    Can you please let me know if you got/found the e-mail and if I should send it again?

    Thanks in advance!

    AvatarZenith
    Participant

    Hello Britgirl,

    I did send the e-mail on 25 February 2020 on 14:53u (or 02:53 pm) to forum[at]nomachine.com and it’s marked as sent. I didn’t receive an error, so it seems it has arrived. I used this as title: ‘Can’t login “Authentication failed, please try again.” (Linux forums)’.

    So I added the ‘(Linux forums)’ part to the title, could that be the problem? Should I send it again?

    Please let me know, thanks in advance!

    AvatarZenith
    Participant

    Sorry for the late response, I was able to collect the debug archive this time. I feel so stupid for forgetting the forward slash before ‘etc’… complete Linux newbie here.

    I mailed the files like you said, can’t wait for the response 🙂

    Thanks in advance

    AvatarZenith
    Participant

    Thanks for the reply!

    I tried the commands:

    etc/NX/nxserver --debug --collect

    and

    etc/NX/server --debug --collect

    since there’s no ‘nxserver’ folder in NX, just ‘server’. Both give me this outcome:

    bash: etc/NX/(nx)server: No such file or directory

    I also tried both commands with sudo in front of it, but that gives me this message:

    sudo etc/NX/(nx)server: command not found

    The only folder present in the ‘server’ folder (in etc/NX) is ‘localhost’.

     

    I DID find the /etc/pam.d folder and found a file called ‘su’. So I copied that to a folder where I save the files needed to provide. But still no luck on collecting the logs from the Linux server… and since I doubt I have a root account or sudoer (?) how will I ever be able to collect the files/logs that you need to be able to help me out?

    I CAN provide the files: nxd.log, nxinstall.log and su. Would that be of any help?

    Thanks in advance

     

    AvatarZenith
    Participant

    Hi,

    Sorry for the late response.

    I tried to do what you said. In var/log there is no auth.log file…

    I can’t find ‘connection details/advanced’ in the player (that is the Windows client right?)

    I used the following command as mentioned in the ‘How to gather debug logs for support requests’ from the Knowledge Base.:

    oem@Zenith:~$ sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log
    [sudo] password for oem:
    tar: Removing leading `/’ from member names
    /usr/NX/var/log/
    /usr/NX/var/log/archives/
    /usr/NX/var/log/nxd.log
    /usr/NX/var/log/logrotate/
    /usr/NX/var/log/node/
    /usr/NX/var/log/nxinstall.log
    /usr/NX/var/log/nxserver.log
    /usr/NX/var/log/nxerror.log
    oem@Zenith:~$

    This produced the following files and folders (if not already present before I executed the command):

    folders: archives, logrotate, node
    files: nxd, nxerror, nxinstall, nxserver (all .log)

    I can’t copy/paste nxerror.log and nxserver.log to my NAS or Windows machine. I get the following error:
    Error opening file /usr/NX/var/log/nxerror.log: Permission Denied. Despite elevated privileges in the log folder.

    I also can’t find the /usr/NX/etc/pam.d/su module configuration. There is nothing located with the name ‘pam.d’ in the etc folder.

    Where do I go from here?

    Thanks in advance

    AvatarZenith
    Participant

    I’m sorry I have not noticed before

    No problem of course!

    This is not an connection attempt to the remote machine. This is an attempt to change settings on the server for the local machine.

    That is correct, but since I noticed that “Changes disabled” lock icon there. Which I never seen before, I thought I made a screenshot of that.

    A screenshot of the Windows Client saying “Authentication failed, please try again.” didn’t seem necessary to post here.

    I’m not quite sure what you mean with “use New connection” or the “nxplayer” application. Here are two screenshots of what I’m seeing in the Windows client:

    So nothing strange there, except the error of course. I emailed the log like you said. Have you any idea what kind of ETA I can expect on an answer?

    Thanks again for the reply!

    AvatarZenith
    Participant

    I just now see that I get an error for this command:
    sudo /usr/NX/bin/nxserver –useradd <username>

    After I try to set the password I get the following error:
    NX> 500 ERROR: Invalid command: ‘-useradd’

    And then followed by a lot info about the various commands and options. So in hindsight, something has gone wrong at this step it seems…

Viewing 15 posts - 1 through 15 (of 17 total)