arliinsandbulte

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • in reply to: Second connection kicks first one out #31910
    Avatararliinsandbulte
    Participant

    I did not notice any difference in behavior with that option checked or unchecked.

    The server computer is a Win10 public PC (you might consider it a kiosk that anyone could walk up to and use).
    When it is booted, the computer is set to log in as a user (username: Bob, for example).  No password is set for the Bob account.
    Most of the time, the PC sits idle, logged in as Bab, with the screen set to turn off after some inactivity.
    Anyone can walk up to it and use it.  Just wake up the screen and start using.  No login or password needed (because it automatically boots into the Bob account and there is no password with that account).

    Others can remote into the PC through NoMachine.  They log on using the Bob account and no password.

    When I enable (check) the option “Server –> Security –> Require permission to let remote users connect”:
    I can still connect to the PC without anyone physically at the PC providing permission.
    Also, when someone else connects to the PC, the first person’s remote session is ended when the second person connects.

    When that option is disabled (unchecked), it behaves the same way.

     

    in reply to: Second connection kicks first one out #31888
    Avatararliinsandbulte
    Participant

    I am using the free version.

    I can live with that limitation as-is.  Just thought there might be a setting to block the second user or at least prompt/notify the first connected user.

    Thanks.

    Avatararliinsandbulte
    Participant

    Update with version 7:

    Version 7 seems to have improved things.  I don’t see this issue every time anymore, but I do still see the same issue.

    So, it seems more random now.
    Sometimes first connection when the PC screen is sleeping, NoMachine works fine.
    Other times, same thing happens and I need to disconnect and reconnect.  After reconnecting, all works great.

    So, that is an improvement.  But, it might be harder to debug now because the issue seems more random.
    On version 6, it happened every time the remote PC’s screen timeout had been reached and the screen was sleeping.

    Avatararliinsandbulte
    Participant

    Thanks.  Any idea when I can expect to see version 7?

    Avatararliinsandbulte
    Participant

    Any more progress looking into this issue?

    Anything more info or details you want from me?

    Avatararliinsandbulte
    Participant

    Another user that remotes into the same PC is on Mac and also sees the same issue when first connecting.

    Avatararliinsandbulte
    Participant

    I have submitted the log files as requested.
    And, I made a video of all the Advanced Power Settings and sent that in an email too.

    Here is some more info on this behavior:

    1. When connecting the first time, I *DO* have mouse and keyboard control of the remote (server) PC, but I cannot see it.  I only see a static image of the remote desktop.  When double click on a desktop icon, nothing happens locally.  But, when I quit NoMachine and connect the second time, the program that I double clicked on is open and running.
    2. On the local machine, when I connect the first time, I see the remote (server) PC desktop, but when I move the mouse, the remote (server) mouse seems to just drift and not follow my local mouse cursor.  (I have show server mouse icon enabled).
    3. The remote (server) PC has 3 screens attached.
    4. The remote (server) PC is configured to login to a standard user (non-admin) account automatically at boot.  This is set by running the netplwiz utility:
      Then, in the User Accounts dialog box, click the account you want to automatically log on to.
      Then, clear the ‘Users Must Enter A User Name And Password To Use This Computer’ check box.
      Then, Click OK

    Hope that helps.  Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)