bakhtadze

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • in reply to: Two-factor auth with Yubikey #15122
    Avatarbakhtadze
    Participant

    Hello,

    two-factor authentication with YubiKey is not supported yet, neither via NX protocol nor with SSH protocol,

    but we have in plan to add it:

    https://www.nomachine.com/FR07N03138

    But at the moment, with some additional configurations is possible to authenticate

    with YubiKey from Linux client to Linux server (via SSH protocol), but not from Windows client.

    If you are interested to this solution, we can provide more details.

    in reply to: Authentication error with correct username #13671
    Avatarbakhtadze
    Participant

    Hello.
    We need some more information for our investigation.

    Can you send us /etc/pam.d folder from Ubuntu also /usr/NX/var/log folder.
    Also output of ‘cut -d: -f1 /etc/passwd’ command.

    And user name you are trying to authenticate with.

    Also output from ‘arch’ command and package name you have installed on Ubuntu.

    Avatarbakhtadze
    Participant

    Hello norbert

    We used your pam config files but we could not reproduce the issue.
    So please can you send us Centrifydc config file and
    pam_centrifydc.so module?

    Please look at the following link:
    http://community.centrify.com/t5/Centrify-Express/Centrify-Express-Smart-Card-on-El-Capitan/td-p/22143

    It explains that you first should update Centrify and then OS.
    Did you update everything as suggested in this article?

    Also, here we have a newer version 5.3, whereas you have (5.2.4).
    Updating to the recent release of Centrify might be an option for you?

    Avatarbakhtadze
    Participant

    We can reproduce this issue by installing to D:\Utilities\Remoting\NoMachine\x86\;
    the installation hangs.

    But if we install to D:\Utilities\Remoting\NoMachine\ then for us everything works fine.

    So it is an installation path problem. This path is too long. It appears to be a limitation in Perl which sets limitations on the path. We’ll open a Trouble Report.

    For now, we suggest to use a shorter path such as D:\NoMachine.

    in reply to: Server does not start properly on Jessie #9376
    Avatarbakhtadze
    Participant

    Hello yakmo,

    There is a second solution too.

    You can follow all steps that where described in previous post. But instead of removing pam_mount entry you can add disable_interactive option next to pam_mount.so.

    It should be like:

    session optional pam_mount.so disable_interactive

    in reply to: NoMachine 4.6.4 PAM problem #7546
    Avatarbakhtadze
    Participant

    Hello
    From the output of your command we can see that your OS is x64 bit architecture.
    The package you have installed is for x32 bit architecture.
    Please remove the current package and install nomachine_4.6.4_13_x86_64.rpm.

    in reply to: NoMachine 4.6.4 PAM problem #7515
    Avatarbakhtadze
    Participant

    Hello

    Please can you run this command: ldconfig -p | grep libpam*

    This command will help us to find what pam libraries are installed on your machine.

Viewing 7 posts - 1 through 7 (of 7 total)